<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
	<head>
		<meta charset="UTF-8">
		<!-- MAKE IT RESPONSIVE -->
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<meta name="mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-capable" content="yes">
				<link rel="profile" href="https://gmpg.org/xfn/11">
		<link rel="pingback" href="https://wesharethis.com/xmlrpc.php">
		<link rel="shortcut icon" type="image/png" href="//wesharethis.com/wp-content/uploads/2017/07/411746.png"><link rel="manifest" href="https://wesharethis.com/wp-content/themes/WesharethisV2/js/manifest.json"><link rel="apple-touch-icon" sizes="114x114" href="//wesharethis.com/wp-content/uploads/2017/07/411746.png"><link rel="apple-touch-icon" sizes="144x144" href="//wesharethis.com/wp-content/uploads/2017/07/411746.png">		<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
		<!--[if lt IE 9]>
		<script src="https://wesharethis.com/wp-content/themes/WesharethisV2/js/html5shiv.js"></script>
		<script src="https://wesharethis.com/wp-content/themes/WesharethisV2/js/respond.min.js"></script>
		<![endif]-->
		<title>Atom for JavaScript Developers &bull; Wesharethis</title>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Atom for JavaScript Developers" />
<meta property="og:description" content="We analyze the usefulness of Sublime Text editor In a post because it has a stable and foolproof stability. Problem: Developed by one person is slow, the documentation is quite obscure. Atom is slow, lag and it&#039;s as resource-intensive as Google Chrome. However, when you code JavaScript, I must admit that using Atom is super cool ! &nbsp; In this article I will show you how I pimpe Atom to be effective when developing fullstack JavaScript web applications. Atom in 10 seconds 1 million active users Created and maintained by GitHub since 2014 Based on Chromium, coded with the framework Electron (With web technologies like CoffeeScript / JavaScript / Less / HTML)" />
<meta property="og:url" content="https://wesharethis.com/2017/08/atom-javascript-developers/" />
<meta property="og:site_name" content="Wesharethis" />
<meta property="article:tag" content="Atom" />
<meta property="article:tag" content="developers" />
<meta property="article:tag" content="JavaScript" />
<meta property="article:section" content="Developer" />
<meta property="article:published_time" content="2017-08-28T20:47:35+00:00" />
<meta property="og:image" content="https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" />

<!-- This site is optimized with the Yoast SEO Premium plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="We analyze the usefulness of Sublime Text editor In a post because it has a stable and foolproof stability. Problem: Developed by one person is slow, the d"/>
<link rel="canonical" href="https://wesharethis.com/2017/08/atom-javascript-developers/" />
<link rel="publisher" href="https://plus.google.com/+Olamouslat"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Atom for JavaScript Developers &bull; Wesharethis" />
<meta property="og:description" content="We analyze the usefulness of Sublime Text editor In a post because it has a stable and foolproof stability. Problem: Developed by one person is slow, the d" />
<meta property="og:url" content="https://wesharethis.com/2017/08/atom-javascript-developers/" />
<meta property="og:site_name" content="Wesharethis" />
<meta property="article:publisher" content="https://facebook.com/wesharethis" />
<meta property="article:tag" content="Atom" />
<meta property="article:tag" content="developers" />
<meta property="article:tag" content="JavaScript" />
<meta property="article:section" content="Developer" />
<meta property="article:published_time" content="2017-08-28T20:47:35+00:00" />
<meta property="fb:app_id" content="1750851391894643" />
<meta property="og:image" content="https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" />
<meta property="og:image:width" content="1026" />
<meta property="og:image:height" content="218" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="We analyze the usefulness of Sublime Text editor In a post because it has a stable and foolproof stability. Problem: Developed by one person is slow, the d" />
<meta name="twitter:title" content="Atom for JavaScript Developers &bull; Wesharethis" />
<meta name="twitter:site" content="@Sharplatloaded" />
<meta name="twitter:image" content="https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" />
<meta name="twitter:creator" content="@Sharplatloaded" />
<meta property="DC.date.issued" content="2017-08-28T20:47:35+00:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Wesharethis &raquo; Feed" href="https://wesharethis.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wesharethis &raquo; Comments Feed" href="https://wesharethis.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wesharethis &raquo; Atom for JavaScript Developers Comments Feed" href="https://wesharethis.com/2017/08/atom-javascript-developers/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wesharethis.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='https://wesharethis.com/wp-includes/css/dashicons.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='admin-bar-css'  href='https://wesharethis.com/wp-includes/css/admin-bar.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='imagify-css-admin-bar-css'  href='https://wesharethis.com/wp-content/plugins/imagify/assets/css/admin-bar.min.css?ver=1.6.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='bp-admin-bar-css'  href='https://wesharethis.com/wp-content/plugins/buddypress/bp-core/css/admin-bar.min.css?ver=2.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='bp-parent-css-css'  href='https://wesharethis.com/wp-content/themes/WesharethisV2/css/buddypress.css?ver=2.9.1' type='text/css' media='screen' />
<link rel='stylesheet' id='es-widget-css-css'  href='https://wesharethis.com/wp-content/plugins/email-subscribers/widget/es-widget.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='toc-screen-css'  href='https://wesharethis.com/wp-content/plugins/table-of-contents-plus/screen.min.css?ver=1509' type='text/css' media='all' />
<link rel='stylesheet' id='yoast-seo-adminbar-css'  href='https://wesharethis.com/wp-content/plugins/wordpress-seo-premium/css/adminbar-490.min.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.6.2/css/font-awesome.min.css?ver=0.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='amarkal-css'  href='https://wesharethis.com/wp-content/plugins/mivhak/vendor/askupa-software/amarkal-framework/Assets/css/amarkal.min.css?ver=0.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='select2-css'  href='https://wesharethis.com/wp-content/plugins/mivhak/vendor/askupa-software/amarkal-framework/Assets/css/select2.min.css?ver=0.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='mivhak-css'  href='https://wesharethis.com/wp-content/plugins/mivhak/assets/css/mivhak.min.css?ver=1.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-builder-frontend-grid-css'  href='https://wesharethis.com/wp-content/plugins/unyson/framework/extensions/builder/static/css/frontend-grid.css?ver=1.2.10' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-forms-default-styles-css'  href='https://wesharethis.com/wp-content/plugins/unyson/framework/extensions/forms/static/css/frontend.css?ver=2.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-css'  href='https://wesharethis.com/wp-content/plugins/Easy%20social%20share/assets/css/easy-social-share-buttons.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-display-methods-css'  href='https://wesharethis.com/wp-content/plugins/Easy%20social%20share/assets/css/essb-display-methods.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='theme-fonts-css'  href='//fonts.googleapis.com/css?family=Lato:100,200,300,400,400italic,600,700italic,800,900|Oswald:100,200,300,400,400italic,600,700italic,800,900' type='text/css' media='all' />
<link rel='stylesheet' id='assets-css-css'  href='https://wesharethis.com/wp-content/themes/WesharethisV2/css/assets.min.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='woffice-theme-style-css'  href='https://wesharethis.com/wp-content/themes/WesharethisV2/style.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='woffice-printed-style-css'  href='https://wesharethis.com/wp-content/themes/WesharethisV2/css/print.min.css?ver=1.0' type='text/css' media='print' />
<link rel='stylesheet' id='buttons-css'  href='https://wesharethis.com/wp-includes/css/buttons.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://wesharethis.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://wesharethis.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='media-views-css'  href='https://wesharethis.com/wp-includes/css/media-views.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='imgareaselect-css'  href='https://wesharethis.com/wp-includes/js/imgareaselect/imgareaselect.css?ver=0.9.8' type='text/css' media='all' />
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var BP_Confirm = {"are_you_sure":"Are you sure?"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/buddypress/bp-core/js/confirm.min.js?ver=2.9.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/buddypress/bp-core/js/widget-members.min.js?ver=2.9.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/buddypress/bp-core/js/jquery-query.min.js?ver=2.9.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-cookie.min.js?ver=2.9.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-scroll-to.min.js?ver=2.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var BP_DTheme = {"accepted":"Accepted","close":"Close","comments":"comments","leave_group_confirm":"Are you sure you want to leave this group?","mark_as_fav":"Favorite","my_favs":"My Favorites","rejected":"Rejected","remove_fav":"Remove Favorite","show_all":"Show all","show_all_comments":"Show all comments for this thread","show_x_comments":"Show all comments (%d)","unsaved_changes":"Your profile has unsaved changes. If you leave the page, the changes will be lost.","view":"View"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/buddypress/bp-templates/bp-legacy/js/buddypress.min.js?ver=2.9.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/wp-a11y.min.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WofficeAutocomplete = {"url":"https:\/\/wesharethis.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/themes/WesharethisV2/js/autocomplete.js?ver=1.0'></script>
<script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?v=3&#038;libraries=places&#038;language=en&#038;key=AIzaSyAPFgz7OV1a1HxCJnQXWCFjw8mIueP-wY4&#038;ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var userSettings = {"url":"\/","uid":"0","time":"1504076528","secure":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/utils.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/plupload/plupload.full.min.js?ver=2.1.8'></script>
<!--[if lt IE 8]>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/json2.min.js?ver=2015-05-03'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://wesharethis.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wesharethis.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://wesharethis.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<link rel='shortlink' href='https://wesharethis.com/?p=7349' />
<link rel="alternate" type="application/json+oembed" href="https://wesharethis.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwesharethis.com%2F2017%2F08%2Fatom-javascript-developers%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wesharethis.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwesharethis.com%2F2017%2F08%2Fatom-javascript-developers%2F&#038;format=xml" />

	<script type="text/javascript">var ajaxurl = 'https://wesharethis.com/wp-admin/admin-ajax.php';</script>

<!-- start Simple Custom CSS and JS -->
<style type="text/css">
/*
Theme Name:  Readme
Theme URI:   http://themeforest.net/user/pixelwars/portfolio
Author:      Pixelwars
Author URI:  http://themeforest.net/user/pixelwars
Description: Responsive WordPress theme.
Version:     1.4.1
License:     ThemeForest License
License URI: http://themeforest.net/licenses
Tags:        light, dark, white
Text Domain: read
*/

/*
    Do not remove any of the commented text above as it is used by the theme for proper function!
*/

/* WordPress Core -------------------------------------------------------------- */

.aligncenter, .alignnone, .alignright, .alignleft {
    display: block; margin: 1.6em auto; clear: both;
	}
.wp-caption {
	color:#555;
	}
.wp-caption img {
	border: 0 none; height: auto; margin: 0; padding: 0;
	}
.wp-caption p.wp-caption-text {
    font-size: 14px; margin: 0; padding: .6em .1em 0; text-align: left; letter-spacing: 2px;
	}
.wp-caption.aligncenter,
.wp-caption.aligncenter .wp-caption-text {
	text-align: center;
	}

/* TABLETS */
@media screen and (min-width: 768px) {
	.alignnone {
		margin: 3em 0; 
		}
	.aligncenter {
		margin: 3em auto; 
		}
	.alignright {
		float:right; margin: .4em 0 1em 2em;
		}
	.alignleft {
		float: left; margin: .4em 2em 1em 0;
		}
	.alignright .wp-caption-text,
	.alignleft p.wp-caption-text {
		max-width: 230px;
		}
}

/* DESKTOPS MEDIUM */
@media screen and (min-width: 1200px) { 
	.content-area:not(.with-sidebar) .alignright, .content-area:not(.with-sidebar) .wp-caption.alignright {
		margin-right: -160px; margin-left: 3em; margin-bottom: 1.4em;
		}
	.content-area:not(.with-sidebar) .alignleft, .content-area:not(.with-sidebar) .wp-caption.alignleft {
		margin-left: -160px; margin-right: 3em; margin-bottom: 1.4em;
		}	
}</style>
<!-- end Simple Custom CSS and JS -->
<!-- start Simple Custom CSS and JS -->
<style type="text/css">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</style>
<!-- end Simple Custom CSS and JS -->
<!-- start Simple Custom CSS and JS -->
<style type="text/css">
@media screen and (min-width: 1025px) {
    .grid-featured {
        margin: 0px -30px;
        max-width: 349px;
    }
}
@media only screen and (max-width: 480px) {
    .genesis-grid-even,
    .genesis-grid-odd {
        width: 100%
    }
}
.genesis-grid-even,
.genesis-grid-odd {
    margin-bottom: 20px;
    width: 48%
}
.content-sidebar-sidebar .sidebar-secondary,
.genesis-grid-even {
    float: right
}
.genesis-grid-odd {
    clear: both;
    float: left
}
.genesis-grid .entry-title,
.genesis-grid .entry-title a {
    font-size: 22px;
    line-height: 1.4!important;
    overflow: hidden
}
.genesis-grid {
    font-size: 16px;
    overflow: hidden;
    line-height: 30px;
    padding: 30px;
}
.entry-meta,
.genesis-grid .entry-meta {
    font-size: 12px
}
.wesharethis-featured {
    margin: 0px -30px;
    max-width: 350px;
}
.wesharethis-img {
    padding-bottom: 20px;
    border: 1px solid #f0f0f0;
    border-radius: 2px;
}
/* ## Featured images above Posts with Title as overlay
----------------------------------------------------- */

.archive-featured-image {
	overflow: hidden;
	position: relative;
}

.archive-featured-image img {
	display: block;
}

.archive-featured-image .entry-title {
	position: absolute;
	top: 50%;
	left: 50%;
	text-shadow: 1px 1px #333;
	text-align: center;
	-webkit-transform: translate(-50%, -50%);
	-moz-transform: translate(-50%, -50%);
	-ms-transform: translate(-50%, -50%);
	-o-transform: translate(-50%, -50%);
	transform: translate(-50%, -50%);
}

.archive-featured-image .entry-title a {
	display: block;
	color: #fff;
}

.image-overlay {
	position: absolute;
	top: 0;
	width: 100%;
	height: 100%;
	opacity: 0.3;
	background-color: #000;
}

@media only screen and (max-width: 800px) {
	.archive-featured-image {
		margin-bottom: 40px;
	}
}

@media only screen and (max-width: 480px) {
	.archive-featured-image {
		margin-bottom: 0;
	}

	.archive-featured-image .entry-title {
		position: static;
		-webkit-transform: none;
		-moz-transform: none;
		-ms-transform: none;
		-o-transform: none;
		transform: none;
	}

	.image-overlay {
		display: none;
	}

	.archive-featured-image .entry-title {
		margin-top: 20px;
		text-shadow: none;
	}

	.archive-featured-image .entry-title a {
		color: #333;
	}

	.archive-featured-image .entry-title a:hover {
		color: #e5554e;
	}
}
/* Comment Policy
---------------------------------------------------------------------------------------------------- */

.comment-policy {
	border: 1px solid #edeeee;
	padding: 20px 30px;
}

.comment-policy p:last-child {
	margin-bottom: 0;
}
/* Previous and next single post navigation links */

.adjacent-entry-pagination {
	background: #fff;
	border-bottom: 1px solid #ddd;
	border-top: 1px solid #ddd;
	margin: 100px 0;
	padding: 0;
}

.single .pagination-next,
.single .pagination-previous {
	font-size: 20px;
	font-weight: 900;
	padding: 60px 0;
	width: 50%;
}

.adjacent-entry-pagination .pagination-previous {
	border-right: 1px solid #ddd;
	float: left;
	padding-right: 15px;
}

.adjacent-entry-pagination .pagination-next {
	float: right;
	padding-left: 15px;
}</style>
<!-- end Simple Custom CSS and JS -->
<!-- Custom CSS from Woffice --><style type="text/css">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</style>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css">body.single {margin-bottom: 46px !important;}</style>
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/wesharethis.com\/wp-admin\/admin-ajax.php","essb3_nonce":"0a26df051a","essb3_plugin_url":"https:\/\/wesharethis.com\/wp-content\/plugins\/Easy social share","essb3_facebook_total":true,"essb3_admin_ajax":false,"essb3_internal_counter":false,"essb3_stats":true,"essb3_ga":false,"essb3_ga_mode":"simple","essb3_counter_button_min":0,"essb3_counter_total_min":0,"blog_url":"https:\/\/wesharethis.com\/","ajax_type":"wp","essb3_postfloat_stay":false,"essb3_no_counter_mailprint":false,"essb3_single_ajax":false,"twitter_counter":"self","post_id":7349};var essb_buttons_exist = !!document.getElementsByClassName("essb_links"); if(essb_buttons_exist == true) { document.addEventListener("DOMContentLoaded", function(event) { var ESSB_CACHE_URL = "https://wesharethis.com/2017/08/atom-javascript-developers/"; if(ESSB_CACHE_URL.indexOf("?") > -1) { ESSB_CACHE_URL += "&essb_counter_cache=rebuild"; } else { ESSB_CACHE_URL += "?essb_counter_cache=rebuild"; }; var xhr = new XMLHttpRequest(); xhr.open("GET",ESSB_CACHE_URL,true); xhr.send(); });}var essbis_settings = {"modules":{"settings":{"moduleHoverActive":1,"activeModules":["settings","buttons","hover"]},"buttons":{"pinterestImageDescription":["titleAttribute","altAttribute","postTitle","mediaLibraryDescription"],"networks":"pinterest"},"hover":{"imageSelector":".essbis-hover-container img","minImageHeight":100,"minImageWidth":100,"hoverPanelPosition":"top-left","theme":"flat-small","orientation":"horizontal","showOnHome":"1","showOnSingle":"1","showOnPage":"1","showOnBlog":"1","showOnLightbox":"1","networks":"pinterest"}},"twitteruser":"","buttonSets":[],"themes":[]};</script><style type="text/css" media="print">#wpadminbar { display:none; }</style>
<style type="text/css" media="screen">
	html { margin-top: 32px !important; }
	* html body { margin-top: 32px !important; }
	@media screen and ( max-width: 782px ) {
		html { margin-top: 46px !important; }
		* html body { margin-top: 46px !important; }
	}
</style>
<script type="text/javascript">
			jQuery(document).ready( function() {
				jQuery("#woffice_poll").submit(ajaxSubmit);
		
				function ajaxSubmit(){
				
					var woffice_poll = jQuery(this).serialize();
				
					jQuery.ajax({
						type:"POST",
						url: "https://wesharethis.com/wp-admin/admin-ajax.php",
						data: woffice_poll,
						success:function(data){
							jQuery("#woffice_ajax_validation").html(data);
						},
						complete:function(){
					        jQuery("#poll-loader").slideUp();
					    }
					});
				
					return false;
				}
			});
			</script><link rel="icon" href="https://wesharethis.com/wp-content/uploads/2017/06/cropped-449433.1.jpg-32x32.png" sizes="32x32" />
<link rel="icon" href="https://wesharethis.com/wp-content/uploads/2017/06/cropped-449433.1.jpg-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://wesharethis.com/wp-content/uploads/2017/06/cropped-449433.1.jpg-180x180.png" />
<meta name="msapplication-TileImage" content="https://wesharethis.com/wp-content/uploads/2017/06/cropped-449433.1.jpg-270x270.png" />
	</head>
	
	
	<!-- START BODY -->
	<body data-rsssl=1 class="bp-legacy post-template-default single single-post postid-7349 single-format-standard admin-bar no-customize-support menu-is-vertical has_fixed_navbar woffice-2-x  essbis_site no-js">

		
			
		<div id="page-wrapper" class="menu-is-closed">

			
			<!-- STARTING THE MAIN NAVIGATION (left side) -->
			<nav id="navigation" class=" navigation-hidden  mobile-hidden">
				<ul id="main-menu" class="main-menu"><li id="menu-item-7086" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7086"><a href="https://www.youtube.com/channel/UC9jaNZ11-Jezou6YRvpbM8Q" >Video Tutorials</a></li>
<li id="menu-item-1518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1518"><a href="#" >Who We Are?</a>
<ul class="sub-menu">
	<li id="menu-item-1521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1521"><a href="https://wesharethis.com/about-us/" >About us</a></li>
	<li id="menu-item-1522" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1522"><a href="https://wesharethis.com/1438-2/" >Terms &#038; Conditions</a></li>
	<li id="menu-item-1520" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1520"><a href="https://wesharethis.com/privacy-policy/" >Privacy Policy</a></li>
	<li id="menu-item-1519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1519"><a href="https://wesharethis.com/faq/" >Faq</a></li>
	<li id="menu-item-2069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2069"><a href="https://wesharethis.com/contact-us/" >Contact us</a></li>
	<li id="menu-item-2068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2068"><a href="https://wesharethis.com/cookies-information/" >Cookies Information</a></li>
</ul>
</li>
<li id="menu-item-6876" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6876"><a href="https://wesharethis.com/category/tips-tricks/developer/" >Developer</a></li>
<li id="menu-item-6875" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6875"><a href="https://wesharethis.com/category/tips-tricks/programming/" >Programming</a></li>
<li id="menu-item-7022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7022"><a href="https://wesharethis.com/category/tips-tricks/wordpress/" >WordPress</a></li>
</ul>			</nav>
			<!-- END MAIN NAVIGATION --> 
		
			
			<!-- STARTING THE NAVBAR (top) --> 
			
						<!-- START HEADER -->
			<header id="main-header" class=" navigation-hidden  has-user ">
			
				<nav id="navbar" class="has_fixed_navbar">
					<div id="nav-left">
						<!-- NAVIGATION TOGGLE -->
                        						<a href="javascript:void(0)" id="nav-trigger"><i class="fa fa-bars"></i></a>
						
						
						 
							<!-- START LOGO -->
							<div id="nav-logo">
								<a href="https://wesharethis.com/">
									<img src="//wesharethis.com/wp-content/uploads/2017/07/411746-1.png" alt="Logo Image">								</a>
							</div>
												
						<!-- USER INFORMATIONS -->
													<div id="nav-user" class="clearfix bp_is_active">
								<a href="https://wesharethis.com/wp-login.php" id="user-login"><i class="fa fa-sign-in"></i></a>							</div>
											</div>
					
					<!-- EXTRA BUTTONS ABOVE THE SIDBAR -->
					<div id="nav-buttons">
						
													<!-- SIDEBAR TOGGLE -->
							<a href="javascript:void(0)" id="nav-sidebar-trigger"><i class="fa fa-long-arrow-right"></i></a>
												
													<!-- SEACRH FORM --> 
							<a href="javascript:void(0)" id="search-trigger"><i class="fa fa-search"></i></a>
												
												
												
					</div>
				
				</nav>
				
				<!-- HIDDEN PARTS TRIGGERED BY JAVASCRIPT -->
				
				<!-- START USER LINKS - WAITING FOR FIRING --><div id="user-sidebar"><header id="user-cover"><a href="" class="clearfix"><img alt='' src='https://secure.gravatar.com/avatar/?s=96&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=192&amp;d=identicon&amp;r=g 2x' class='avatar avatar-96 photo avatar-default' height='96' width='96' /><span>Welcome <span class="woffice-welcome"></span></span></a><div class="user-cover-layer"></div></header><nav><ul id="menu-bp" class="menu"><li id="activity-personal-li" class="menu-parent">
					<a href="https://wesharethis.com/activity-streams/">Activity <span class="count">1</span></a>
					<ul class="sub-menu">
						<li id="just-me-personal-li" class="menu-child">
							<a href="activity/">Activity</a>
						</li>
						<li id="activity-mentions-personal-li" class="menu-child">
							<a href="activity/mentions/">Mentions</a>
						</li>
						<li id="activity-favs-personal-li" class="menu-child">
							<a href="activity/favorites/">Favorites</a>
						</li><li id="activity-friends-personal-li" class="menu-child">
							<a href="activity/friends/">Friends</a>
						</li><li id="activity-groups-personal-li" class="menu-child">
							<a href="activity/groups/">Groups</a>
						</li></ul>
			</li><li id="xprofile-personal-li" class="menu-parent">
                    <a href="">Profile </a>
                    <ul class="sub-menu">
                        <li id="public-personal-li" class="menu-child">
                            <a href="profile/">View</a>
                        </li>
                        <li id="edit-personal-li" class="menu-child">
                            <a href="profile/edit/">Edit</a>
                        </li><li id="change-avatar-personal-li" class="menu-child">
                            <a href="profile/change-avatar/">Change Profile Photo</a>
                        </li></ul>
            </li><li id="notifications-personal-li" class="menu-parent">
                <a href="notifications/">Notifications <span class="count">11</span></a><ul class="sub-menu">
					<li id="notifications-my-notifications-personal-li" class="menu-child">
						<a href="notifications/">Unread</a>
					</li>
					<li id="read-personal-li" class="menu-child">
						<a href="notifications/read/">Read</a>
					</li>
				</ul>
			</li><li id="messages-personal-li" class="menu-parent">
            	<a href="messages/">Messages </a><ul class="sub-menu">
					<li id="inbox-personal-li" class="menu-child">
						<a href="messages/">Inbox</a>
					</li>
					<li id="starred-personal-li" class="menu-child">
						<a href="messages/starred/">Starred</a>
					</li>
					<li id="sentbox-personal-li" class="menu-child">
						<a href="messages/sentbox/">Sent</a>
					</li>
					<li id="compose-personal-li" class="menu-child">
						<a href="messages/compose/">Compose</a>
					</li>
					<li id="notices-personal-li" class="menu-child">
						<a href="messages/notices/">Notices</a>
					</li>
				</ul>
			</li><li id="friends-personal-li" class="menu-parent">
                <a href="friends/">Friends </a><ul class="sub-menu">
					<li id="friends-my-friends-personal-li" class="menu-child">
						<a href="friends/">Friendships</a>
					</li>
					<li id="requests-personal-li" class="menu-child">
						<a href="friends/requests/">Requests</a>
					</li>
				</ul>
			</li><li id="groups-personal-li" class="menu-parent">
            	<a href="groups/">Groups </a><ul class="sub-menu">
					<li id="groups-my-groups-personal-li" class="menu-child">
						<a href="groups/">Memberships</a>
					</li>
					<li id="invites-personal-li" class="menu-child">
						<a href="groups/invites/">Invitations</a>
					</li>
				</ul>
			</li><li id="settings-personal-li" class="menu-parent">
                    <a href="settings/">Settings </a>
                    <ul class="sub-menu">
                        <li id="general-personal-li" class="menu-child">
                            <a href="settings/">General</a>
                        </li>
                        <li id="notifications-personal-li" class="menu-child">
                            <a href="settings/notifications/">Email</a>
                        </li>
                        <li id="profile-personal-li" class="menu-child">
                            <a href="settings/profile/">Profile Visibility</a>
                        </li>
                    </ul>
                </li><li id="logout-li"><a href="https://wesharethis.com/wp-login.php?action=logout&amp;_wpnonce=1a8a4a208e">Log Out</a></li></ul></nav></div>				
								
					
									<!-- START SEARCH CONTAINER - WAITING FOR FIRING -->
					<div id="main-search">
						<div class="container">
							<form role="search" method="get" action="https://wesharethis.com/" >
                <input type="text" value="" name="s" id="s" placeholder="Search..."/>
                <input type="hidden" name="searchsubmit" id="searchsubmit" value="true" />
                <button type="submit" name="searchsubmit"><i class="fa fa-search"></i></button>
            </form>						</div>
					</div>
									
			</header>
				
			<!-- END NAVBAR --> 
			
			
			<!-- STARTING THE SIDEBAR (righ side) + content behind --> 
			
				
			<!-- START CONTENT -->
			<section id="main-content" class="with-sidebar  navigation-hidden ">
			
					<!-- RIGHT SIDE -> SIDEBAR-->
	<aside id="right-sidebar" class="mobile-hidden" role="complementary">

		<div id="email-subscribers-2" class="widget widget_text elp-widget"><div class="intern-padding"><div class="intern-box box-title"><h3>Subscribe to Updates</h3></div>
		<div>
			<form class="es_widget_form" data-es_form_id="es_widget_form">
									<div class="es_caption">Be part of this community and be the first to know when new tutorials are published</div>
													<div class="es_lablebox"><label class="es_widget_form_name">Name</label></div>
					<div class="es_textbox">
						<input type="text" id="es_txt_name" class="es_textbox_class" name="es_txt_name" value="" maxlength="225">
					</div>
								<div class="es_lablebox"><label class="es_widget_form_email">Email *</label></div>
				<div class="es_textbox">
					<input type="text" id="es_txt_email" class="es_textbox_class" name="es_txt_email" onkeypress="if(event.keyCode==13) es_submit_page(event,'https://wesharethis.com')" value="" maxlength="225">
				</div>
				<div class="es_button">
					<input type="button" id="es_txt_button" class="es_textbox_button es_submit_button" name="es_txt_button" onClick="return es_submit_page(event,'https://wesharethis.com')" value="Subscribe">
				</div>
				<div class="es_msg" id="es_widget_msg">
					<span id="es_msg"></span>
				</div>
								<input type="hidden" id="es_txt_group" name="es_txt_group" value="">
			</form>
		</div>
		</div></div><div id="recent-comments-3" class="widget widget_recent_comments"><div class="intern-padding"><div class="intern-box box-title"><h3>Recent Comments</h3></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://techrights.org/2017/08/28/gnupg-2-2-released/"  rel='external nofollow' class='url'>Links 28/8/2017: Linux 4.13 RC7, GnuPG 2.2 Released | Techrights</a></noindex><!--/noindex--></span> on <a href="https://wesharethis.com/2017/08/raid-getting-hard-drives/#comment-218">RAID: getting the most out of your hard drives</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://wesharethis.com/2017/08/hayaku-write-css-faster/' rel='external nofollow' class='url'>Hayaku - Write CSS faster &bull; Wesharethis</a></span> on <a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/#comment-217">Coding more effectively with Sublime Text</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://wesharethis.com/2017/08/atom-javascript-developers/' rel='external nofollow' class='url'>Atom for JavaScript Developers &bull; Wesharethis</a></span> on <a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/#comment-216">Coding more effectively with Sublime Text</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://wesharethis.com' rel='external nofollow' class='url'>Ahmad</a></span> on <a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/#comment-215">Coding more effectively with Sublime Text</a></li><li class="recentcomments"><span class="comment-author-link">Nicolas dalpe</span> on <a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/#comment-213">Coding more effectively with Sublime Text</a></li></ul></div></div><div id="woffice_wiki-3" class="widget widget_woffice_wiki"><div class="intern-padding"><div class="widget_wiki intern-box box-title"><h3>Recent Wiki Guides</h3></div>	<!-- WIDGET -->
	<ul class="list-styled list-wiki">
		<li class="is-publish"><a href="https://wesharethis.com/wiki/subnet-masks/" rel="bookmark" data-post-id="7221">Subnet masks</a></li><li class="is-draft"><a href="https://wesharethis.com/?post_type=wiki&p=7203" rel="bookmark" data-post-id="7203">Htop and Atop</a></li><li class="is-publish"><a href="https://wesharethis.com/wiki/sed-command-nazes/" rel="bookmark" data-post-id="7197">The sed command for nazes</a></li><li class="is-draft"><a href="https://wesharethis.com/?post_type=wiki&p=7150" rel="bookmark" data-post-id="7150">Mastering MySQL in CLI</a></li><li class="is-publish"><a href="https://wesharethis.com/wiki/the-awk-command/" rel="bookmark" data-post-id="7140">The awk command</a></li><li class="is-publish"><a href="https://wesharethis.com/wiki/what-is-linux/" rel="bookmark" data-post-id="6941">What is linux</a></li>	</ul>
</div></div>		
	</aside>			
								
				
			<!-- END SIDEBAR --> 
		
		
		
	
	
		<div id="left-content">

			<!-- START FEATURED IMAGE AND TITLE --><header id="featuredbox" class="centered "><div class="pagetitle animate-me fadeIn"><h1>Discover our indept tutorials</h1></div><div class="featured-background" style="background-image:url(//wesharethis.com/wp-content/uploads/2017/08/atom-love.png);"><style>
	        @media screen and (max-width: 800px) {
		        .featured-background {
			        background-image: url("https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png") !important;
				  background-image: 
				    -webkit-image-set(
					    "https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" 1x,
				      "https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" 2x,
				    ) !important;
				  background-image: 
				    image-set(
					    "https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" 1x,
				      "https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" 2x,
				    ) !important;
				}
	        }
			</style><div class="featured-background">
				<div class="featured-layer"></div>
			</div></header> 	

			<!-- START THE CONTENT CONTAINER -->
			<div id="content-container">
				<!-- START CONTENT -->
				<div id="content">
						
						
	<article id="post-7349" class="box content post-7349 post type-post status-publish format-standard has-post-thumbnail hentry category-developer tag-atom tag-developers tag-javascript">
					<!-- THUMBNAIL IMAGE -->
			
            <div class="intern-thumbnail " style="height: 250px;">
                
                    <picture><source srcset="https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" media="(min-width: 801px)" /><img src="https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" /></picture>
                                </div>
            
		
        		<div class="intern-padding heading-container">
							<div class="heading"><h2>Atom for JavaScript Developers</h2></div>					</div>
        
					<div class="intern-box">
				<ul class="post-metadatas list-inline"><li><i class="fa fa-clock-o"></i> August 28, 2017</li><li><span class="author vcard"><i class="fa fa-user" aria-hidden="true"></i><a class="url fn n" href="https://wesharethis.com/author/ahmad/">Ahmad</a></span></li><li><i class="fa fa-comments-o"></i> <a href="https://wesharethis.com/2017/08/atom-javascript-developers/#respond">0</a></li><li><i class="fa fa-thumb-tack"></i> <a href="https://wesharethis.com/category/tips-tricks/developer/" rel="category tag">Developer</a></li><li class="meta-tags"><i class="fa fa-tags"></i> <a href="https://wesharethis.com/tag/atom/" rel="tag">Atom</a>, <a href="https://wesharethis.com/tag/developers/" rel="tag">developers</a>, <a href="https://wesharethis.com/tag/javascript/" rel="tag">JavaScript</a></li></ul>			</div>
				<div class="intern-padding clearfix">
						<p class="blog-sum-up">
				                    <input type="hidden" value="" data-essbisPostContainer="" data-essbisPostUrl="https://wesharethis.com/2017/08/atom-javascript-developers/" data-essbisPostTitle="Atom for JavaScript Developers" data-essbisHoverContainer=""><div style="position:absolute;top:0;left:-9999px;">Want create site? Find <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://dlwordpress.com/"  >Free WordPress Themes</a></noindex><!--/noindex--> and plugins.</div><div class="essb_postbar_start"></div>
<p>We analyze the usefulness of <a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/">Sublime Text </a>editor In a post because it has a stable and foolproof stability. <strong>Problem</strong>: Developed by one person is slow, the documentation is quite obscure.</p>
<p>Atom is slow, lag and it&#8217;s as resource-intensive as Google Chrome. However, when you code JavaScript, I must admit that using <strong>Atom is super cool</strong> !</p>
<p>&nbsp;</p>
<p><img class="aligncenter size-full wp-image-7358" src="https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png" alt="Atom + JavaScript = love" width="1026" height="218" srcset="https://wesharethis.com/wp-content/uploads/2017/08/atom-love.png 1026w, https://wesharethis.com/wp-content/uploads/2017/08/atom-love-300x64.png 300w, https://wesharethis.com/wp-content/uploads/2017/08/atom-love-768x163.png 768w, https://wesharethis.com/wp-content/uploads/2017/08/atom-love-1024x218.png 1024w" sizes="(max-width: 1026px) 100vw, 1026px" />In this article I will show you how I pimpe Atom to be effective when developing fullstack JavaScript web applications.</p>
<div id="toc_container" class="toc_transparent no_bullets"><p class="toc_title">Table of Contents</p><ul class="toc_list"><li><a href="#Atomin_10_seconds"><span class="toc_number toc_depth_1">1</span> Atom in 10 seconds</a></li><li><a href="#Configuration_for_basic_and_community_packs"><span class="toc_number toc_depth_1">2</span> Configuration for basic and community packs</a></li><li><a href="#Do_not_make_me_think_8211_Use_linter"><span class="toc_number toc_depth_1">3</span> Do not make me think &#8211; Use linter</a><ul><li><a href="#Teamwork_witheditorconfig"><span class="toc_number toc_depth_2">3.1</span> Teamwork with editorconfig</a></li><li><a href="#HTML_withlinter-htmlhint"><span class="toc_number toc_depth_2">3.2</span> HTML with linter-htmlhint</a></li><li><a href="#JavaScript_withlinter-eslint"><span class="toc_number toc_depth_2">3.3</span> JavaScript with linter-eslint</a></li></ul></li><li><a href="#Autocomplete_withatom-ternjs"><span class="toc_number toc_depth_1">4</span> Autocomplete with atom-ternjs</a><ul><li><a href="#Configuration"><span class="toc_number toc_depth_2">4.1</span> Configuration</a></li></ul></li><li><a href="#bonus"><span class="toc_number toc_depth_1">5</span> bonus</a></li></ul></div>
<h2 id="atomhttpsatomio-en-10-secondes"><span id="Atomin_10_seconds"><!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://atom.io/"  >Atom</a></noindex><!--/noindex--> in 10 seconds</span></h2>
<ul>
<li><strong>1 million</strong> active <strong>users</strong></li>
<li>Created and <strong>maintained by GitHub</strong> since 2014</li>
<li>Based on Chromium, coded with the framework <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://electron.atom.io/"  >Electron</a></noindex><!--/noindex--> (With web technologies like CoffeeScript / JavaScript / Less / HTML)</li>
<li><strong>Easily editable</strong> with plug-ins written in Node.js (see the <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://flight-manual.atom.io/hacking-atom/sections/tools-of-the-trade/"  >hacker&#8217;s manual</a></noindex><!--/noindex--> )</li>
<li>Very good <strong>integration with git</strong> and GitHub</li>
</ul>
<p><code>alt</code>+ <code>cmd</code>+ <code>i</code>And 💥 you open the <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://en.wikipedia.org/wiki/Chromium_(navigateur_web)"  >Chromium</a></noindex><!--/noindex--> console. This is where <strong>coding from JavaScript directly into a web browser</strong> makes sense.</p>
<h2 id="configuration-pour-les-packets-de-base-et-ceux-de-la-communaut"><span id="Configuration_for_basic_and_community_packs">Configuration for basic and community packs</span></h2>
<p>With a simple <code>cmd + ?</code>you access the configuration of Atom. Even if I prefer the <a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/">customization of Sublime Text</a> you should quickly be able to configure your interface.</p>
<p>&nbsp;</p>
<p><code><img class="aligncenter size-full wp-image-7353" src="https://wesharethis.com/wp-content/uploads/2017/08/settings-packages.gif" alt="Atom settings packages" width="864" height="446" />cmd + shift + P</code> Allows you to search, install new packages and themes.</p>
<p>&nbsp;</p>
<p><img class="aligncenter size-full wp-image-7354" src="https://wesharethis.com/wp-content/uploads/2017/08/install-packages.gif" alt="Atom install packages" width="1076" height="423" />A strong integration between git and GitHub saves a lot of time. The commands I use most are <code>blame</code>(Open on GitHub: Blame) and <code>issues</code>(Open on GitHub: Issues)</p>
<p>&nbsp;</p>
<h2 id="dont-make-me-think--use-linter"><span id="Do_not_make_me_think_8211_Use_linter"><img class="aligncenter size-full wp-image-7355" src="https://wesharethis.com/wp-content/uploads/2017/08/atom-git-integration-1.png" alt="Atom git integration" width="1676" height="984" srcset="https://wesharethis.com/wp-content/uploads/2017/08/atom-git-integration-1.png 1676w, https://wesharethis.com/wp-content/uploads/2017/08/atom-git-integration-1-300x176.png 300w, https://wesharethis.com/wp-content/uploads/2017/08/atom-git-integration-1-768x451.png 768w, https://wesharethis.com/wp-content/uploads/2017/08/atom-git-integration-1-1024x601.png 1024w" sizes="(max-width: 1676px) 100vw, 1676px" />Do not make me think &#8211; Use linter</span></h2>
<p>I work on different technologies that have their specificity. To have a better DX and a scalable code of quality it is <strong>essential to have different tools of analysis of HTML and JavaScript code</strong> .</p>
<h3 id="travail-dquipe-avec-editorconfig"><span id="Teamwork_witheditorconfig">Teamwork with <code>editorconfig</code></span></h3>
<p>Personally when I develop &#8211; like Google &#8211; <strong>I use 2 spaces without tabs</strong> . This detail may seem annodin but if you use different rules in a team you arrive very quickly at a project or the only rule is chaos.</p>
<p>Yes, I am talking to developers who do not encode your files in UTF8 when backing up or do not add a <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://robots.thoughtbot.com/no-newline-at-end-of-file"  >character at the end of the file</a></noindex><!--/noindex--> .</p>
<p>However, it is very easy to solve these problems. Here is a sample file <code>.editorconfig</code>at the root of the project.</p>
<div class="highlight">
<pre class="highlight shell"><code>  <span class="c"># EditorConfig is awesome: http://EditorConfig.org</span>

  root <span class="o">=</span> <span class="nb">true</span>

  <span class="o">[</span><span class="k">*</span><span class="o">]</span>
  charset <span class="o">=</span> utf-8
  indent_style <span class="o">=</span> space
  indent_size <span class="o">=</span> 2
  end_of_line <span class="o">=</span> lf
  trim_trailing_whitespace <span class="o">=</span> <span class="nb">true
  </span>insert_final_newline <span class="o">=</span> <span class="nb">true</span>

  <span class="o">[</span><span class="k">*</span>.md]
  <span class="o">[</span><span class="k">*</span>.markdown]
  trim_trailing_whitespace <span class="o">=</span> <span class="nb">false</span>
</code></pre>
</div>
<h3 id="html-avec-linter-htmlhint"><span id="HTML_withlinter-htmlhint">HTML with <code>linter-htmlhint</code></span></h3>
<p><!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://htmlhint.com/"  >Htmlhint</a></noindex><!--/noindex--> is an HTML analysis tool that will help you avoid the syndrome of the closing ghost tag 👻.</p>
<p>Create a file <code>.htmlhintrc</code>in your project and add the following rules:</p>
<div class="highlight">
<pre class="highlight json"><code>  <span class="err">#</span> <span class="err">Good</span> <span class="err">hunter</span> <span class="err">use</span> <span class="err">HTMLHint</span> <span class="err">https</span><span class="p">:</span><span class="err">//github.com/yaniswang/HTMLHint</span>

  <span class="p">{</span>
    <span class="s2">"attr-lowercase"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"attr-no-duplication"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"attr-unsafe-chars"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"attr-value-double-quotes"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"attr-value-not-empty"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"doctype-first"</span><span class="p">:</span> <span class="kc">false</span><span class="p">,</span>
    <span class="s2">"doctype-html5"</span><span class="p">:</span> <span class="kc">false</span><span class="p">,</span>
    <span class="s2">"head-script-disabled"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"href-abs-or-rel"</span><span class="p">:</span> <span class="kc">false</span><span class="p">,</span>
    <span class="s2">"id-class-ad-disabled"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"id-class-value"</span><span class="p">:</span> <span class="s2">"dash"</span><span class="p">,</span>
    <span class="s2">"id-unique"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"img-alt-require"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"space-tab-mixed-disabled"</span><span class="p">:</span> <span class="kc">false</span><span class="p">,</span>
    <span class="s2">"spec-char-escape"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"src-not-empty"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"style-disabled"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"tag-pair"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"tag-self-close"</span><span class="p">:</span> <span class="kc">false</span><span class="p">,</span>
    <span class="s2">"tagname-lowercase"</span><span class="p">:</span> <span class="kc">true</span>
  <span class="p">}</span>
</code></pre>
</div>
<h3 id="javascript-avec-linter-eslint"><span id="JavaScript_withlinter-eslint">JavaScript with <code>linter-eslint</code></span></h3>
<p><!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://eslint.org/"  >Eslint</a></noindex><!--/noindex--> is a code analysis utility <a href="https://wesharethis.com/2017/07/install-node-js-debian-linux/">Node.js. </a>It is often used to identify problems with code patterns that violate certain conventions.</p>
<p>&nbsp;</p>
<p><img class="aligncenter size-full wp-image-7356" src="https://wesharethis.com/wp-content/uploads/2017/08/linter-js.gif" alt="Atom linter JavaScript" width="804" height="225" />Each project is different but you can start with the configuration used by <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://github.com/ChtiJS/eslint-config"  >JavaScript Developers</a></noindex><!--/noindex-->.</p>
<div class="highlight">
<pre class="highlight shell"><code>  <span class="nv">$ </span>npm install @chtijs/eslint-config <span class="nt">--save-dev</span>
</code></pre>
</div>
<p>In your file <code>.eslintrc</code></p>
<div class="highlight">
<pre class="highlight json"><code>  <span class="p">{</span>
    <span class="s2">"extends"</span><span class="p">:</span> <span class="s2">"@chtijs"</span>
  <span class="p">}</span>
</code></pre>
</div>
<p>You can create your own configuration using the <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://eslint.org/docs/user-guide/getting-started"  >Eslint documentation</a></noindex><!--/noindex-->, or you can separate the configuration for your Backend and Front-end like <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://github.com/SimpliField/eslint-config-simplifield"  >SimpliField</a></noindex><!--/noindex-->.</p>
<h2 id="autocomplete-avec-atom-ternjs"><span id="Autocomplete_withatom-ternjs">Autocomplete with <code>atom-ternjs</code></span></h2>
<p><!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://ternjs.net/"  >Tern</a></noindex><!--/noindex--> is an independent <strong>JavaScript code analysis engine</strong> . It integrates into any editor, in our case it will be a <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/http://ternjs.net/#plugins"  >plugin for Atom</a></noindex><!--/noindex-->. Its main features are:</p>
<ul>
<li>Autocompletion of variables and methods</li>
<li>Displaying Function Arguments</li>
<li>Querying the type of expression</li>
<li>Find definition of something</li>
<li>Automatic refactoring</li>
</ul>
<h3 id="configuration"><span id="Configuration">Configuration</span></h3>
<ul>
<li>Open any JavaScript file in your project</li>
<li><code>Packages</code> <strong>&gt; </strong><code>Atom Ternjs</code> <strong>&gt;</strong> <code>Configure project</code></li>
<li>The configuration file appears.</li>
<li><em>&#8220;Save &amp; Restart Server&#8221;</em> to create / update the file<code>.tern-project</code></li>
</ul>
<div class="highlight">
<pre class="highlight json"><code><span class="p">{</span>
  <span class="s2">"ecmaVersion"</span><span class="p">:</span> <span class="mi">6</span><span class="p">,</span>
  <span class="s2">"libs"</span><span class="p">:</span> <span class="p">[],</span>
  <span class="s2">"loadEagerly"</span><span class="p">:</span> <span class="p">[],</span>
  <span class="s2">"dontLoad"</span><span class="p">:</span> <span class="p">[</span>
    <span class="s2">"node_modules/**"</span><span class="p">,</span>
    <span class="s2">"bower_components/**"</span>
  <span class="p">],</span>
  <span class="s2">"plugins"</span><span class="p">:</span> <span class="p">{</span>
    <span class="s2">"doc_comment"</span><span class="p">:</span> <span class="kc">true</span><span class="p">,</span>
    <span class="s2">"angular"</span><span class="p">:</span> <span class="p">{}</span>
  <span class="p">}</span>
<span class="p">}</span>
</code></pre>
</div>
<p><em>Sample file <code>.tern-project</code>for an AngularJS application</em></p>
<p>If it does not work you can <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://atom.io/packages/atom-ternjs#installation"  >consult the documentation</a></noindex><!--/noindex--></p>
<h2 id="bonus"><span id="bonus">bonus</span></h2>
<p>There are still plenty of other Atom extensions I use &#8211; mostly for web development.</p>
<ul>
<li>emmet</li>
<li>git-time machine</li>
<li>atom-pigments</li>
<li>file-icons</li>
<li>lodash-snippets</li>
<li>js-hyperclick</li>
</ul>
<p>💥 To install everything in one go, simply copy and paste this line into your preferred device</p>
<div class="highlight">
<pre class="highlight shell"><code>  <span class="nv">$ </span>apm editorconfig atom-ternjs file-icons set-syntax sort-lines autocomplete-modules emmet es6-javascript js-hyperclick hyperclick pigments linter-eslint lodash-snippets
</code></pre>
</div>
<p>If you want to optimize the Atom chargment you can always analyze different plugins loading time with <code>Package</code> <strong>&gt; </strong><code>Timecop</code> <strong>&gt;</strong> <code>Show</code></p>
<p>&nbsp;</p>
<p><img class="aligncenter size-full wp-image-7357" src="https://wesharethis.com/wp-content/uploads/2017/08/timecop.png" alt="Atom show plugin loading time" width="598" height="910" srcset="https://wesharethis.com/wp-content/uploads/2017/08/timecop.png 598w, https://wesharethis.com/wp-content/uploads/2017/08/timecop-197x300.png 197w" sizes="(max-width: 598px) 100vw, 598px" />I am curious to know what it is missing, do not hesitate to <strong>send me your config</strong> if you use a Framework like React 🚀</p>
<p><b>Hey don&#8217;t forget to look at the</b> <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://medium.com/productivity-freak/my-atom-editor-setup-for-js-react-9726cd69ad20"  >answer to my question</a></noindex><!--/noindex--></p>
<div class="essb_postbar_end"></div>
<div style="position:absolute;top:0;left:-9999px;">Did you find apk for android? You can find new <!--noindex--><noindex><a target="_blank" rel="nofollow" href="https://wesharethis.com/goto/https://dlandroid24.com/"  >Free Android Games</a></noindex><!--/noindex--> and apps.</div><div class="essb_break_scroll"></div>				
							</p>
			
			
	  			  			<div class="blog-authorbox clearfix">
	  				<img alt='' src='//www.gravatar.com/avatar/fceea1f9f5eee77cbbc9700877866adc?s=96&#038;r=g&#038;d=identicon' srcset='//www.gravatar.com/avatar/fceea1f9f5eee77cbbc9700877866adc?s=96&#038;r=g&#038;d=identicon 2x' class='avatar avatar-96 photo' height='96' width='96' />	  				<div class="blog-authorbox-right">

                        		  				<div class="blog-like-container">
			  				<p class="like-text">Have you enjoyed the post ?</p><p class="wiki-like"><a href="javascript:void(0)" data-post_id="7349">
							                <i class="fa fa-thumbs-o-up"></i>
							            </a><span class="count">0</span></p>						</div>
                        		  						  				<h3><a href="https://wesharethis.com/members/ahmad/">Ahmad</a></h3>		  				<p>Am a tech geek.. Do you wanna know more about me..?  My contents will do tell you.</p>	  				</div>
	  			</div>	
	  						
			
		<hr><div class="blog-next-page center animate-me fadeInUp" role="navigation">
<a class="btn btn-default" href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/" rel="prev"><i class="fa fa-hand-o-left"></i> Coding more effectively with Sublime Text</a><a class="btn btn-default" href="https://wesharethis.com/2017/08/hayaku-write-css-faster/" rel="next">Hayaku &#8211; Write CSS faster <i class="fa fa-hand-o-right"></i></a></div>
	  		
	  				</div>
	</article>

											
					
						

<!-- THE COMMENT FORM --> 
<div class="box">
	<div class="intern-padding">
			
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/08/atom-javascript-developers/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://wesharethis.com/wp-comments-post.php" method="post" id="comment-form" class="comment-form form-horizontal" novalidate>
				<p class="comment-form-comment"><label for="comment">Comment</label> <textarea class="bp-suggestions" id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea class="bp-suggestions"></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='7349' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3173048752" /></p><div class="control-group text-right"><button class="btn btn-default" type="submit"><i class="fa fa-paper-plane-o"></i>Post Comment</button></div><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="171"/></p>			</form>
			</div><!-- #respond -->
		</div>
</div>
					
					
				</div>
					
			</div><!-- END #content-container -->
		
			            <!--SCROLL TOP-->
            <div id="scroll-top-container">
                <a href="#main-header" id="scroll-top">
                    <i class="fa fa-arrow-circle-o-up"></i>
                </a>
            </div>
        
		</div><!-- END #left-content -->
		
	
				
								

				<a href="javascript:void(0)" id="can-scroll"><i class="fa fa-angle-double-down"></i></a>			
			</section>
			<!-- END CONTENT -->
			<!-- START FOOTER -->
            			<footer id="main-footer" class=" navigation-hidden ">
				
				
				
				<!-- START COPYRIGHT -->
				<div id="copyright">
									  	<p><small><italic>Welcome ! Wesharethis is a community dedicated to learning programming, networking and web standards (LINUX, UBUNTU, HTML, CSS, JavaScript), design and digital accessibility. You will find tutorials, forum, job announcements, quizzes, contests and much more. Create your <a href="//wesharethis.com/register ">profile</a>. in seconds to participate!</italic></small>
<br/>&#169; 2017 all rights reserved. Powered by <a href="//wesharethis.com ">Wesharethis</a>.</p>
				</div>
			</footer>
			<!-- END FOOTER -->

		</div>


		<!-- JAVSCRIPTS BELOW AND FILES LOADED BY WORDPRESS -->
		<div id="essb-postbar" class="essb-postbar"><div class="essb-postbar-container"><div class="essb-postbar-prev-post"><a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/"><i class="essb_icon_prev"></i></a><div class="essb_prev_post"><div class="essb_prev_post_info"><div class="essb-postbar-close-postpopup essb-postbar-close-prev">X</div><a href="https://wesharethis.com/2017/08/coding-effectively-sublime-text/"><span class="essb_title"><span class="essb_tcategory">Coding more effectively with Sublime Text</span><span class="essb_category">Developer</span><span class="essb_tdesc">If I remember correctly, the first  software I used to "develop" a website was Frontpage. All those of the pre-ADSL generation have surely started o&hellip;</span></span></a></div></div></div><div class="essb-postbar-category"><a href="https://wesharethis.com/category/tips-tricks/developer/">Developer</a></div><div class="essb-postbar-titleholder"><h2>Atom for JavaScript Developers</h2><span class="essb-postbar-author">by Ahmad</span></div><div class="essb-postbar-right"><div class="essb-posbar-icons-container"><span class="essb-postbar-comments"><i class="essb_icon_comments"></i><span class="essb-postbar-number">0</span></span><span class="essb-postbar-time"><i class="essb_icon_clock"></i><span class="essb-postbar-number">3 min</span></span></div><div class="essb-postbar-buttons"><div class="essb_links essb_displayed_postbar essb_share essb_template_light-retina essb_1432656283 essb_links_center print-no" id="essb_displayed_postbar_1432656283" data-essb-postid="7349" data-essb-position="postbar" data-essb-button-style="icon" data-essb-template="light-retina" data-essb-counter-pos="hidden" data-essb-url="https://wesharethis.com/2017/08/atom-javascript-developers/" data-essb-twitter-url="https://wesharethis.com/2017/08/atom-javascript-developers/" data-essb-instance="1432656283"><ul class="essb_links_list essb_force_hide_name essb_force_hide"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://wesharethis.com/2017/08/atom-javascript-developers/&t=Atom+for+JavaScript+Developers&redirect_uri=https://wesharethis.com?sharing-thankyou=yes" title="" onclick="essb_window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://wesharethis.com/2017/08/atom-javascript-developers/&t=Atom+for+JavaScript+Developers&redirect_uri=https://wesharethis.com?sharing-thankyou=yes&#39;,&#39;facebook&#39;,&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb_window(&#39;https://twitter.com/intent/tweet?text=Atom+for+JavaScript+Developers&amp;url=https://wesharethis.com/2017/08/atom-javascript-developers/&amp;counturl=https://wesharethis.com/2017/08/atom-javascript-developers/&#39;,&#39;twitter&#39;,&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://wesharethis.com/2017/08/atom-javascript-developers/" title="" onclick="essb_window(&#39;https://plus.google.com/share?url=https://wesharethis.com/2017/08/atom-javascript-developers/&#39;,&#39;google&#39;,&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_google"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb_pinterest_picker(&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Atom+for+JavaScript+Developers&amp;url=https://wesharethis.com/2017/08/atom-javascript-developers/" title="" onclick="essb_window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Atom+for+JavaScript+Developers&amp;url=https://wesharethis.com/2017/08/atom-javascript-developers/&#39;,&#39;linkedin&#39;,&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb_print(&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_print"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_reddit nolightbox"> <a href="http://reddit.com/submit?url=https://wesharethis.com/2017/08/atom-javascript-developers/&amp;title=Atom+for+JavaScript+Developers" title="" onclick="essb_window(&#39;http://reddit.com/submit?url=https://wesharethis.com/2017/08/atom-javascript-developers/&amp;title=Atom+for+JavaScript+Developers&#39;,&#39;reddit&#39;,&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_mwp nolightbox"> <a href="http://managewp.org/share/form?url=https%3A%2F%2Fwesharethis.com%2F2017%2F08%2Fatom-javascript-developers%2F" title="" onclick="essb_window(&#39;http://managewp.org/share/form?url=https%3A%2F%2Fwesharethis.com%2F2017%2F08%2Fatom-javascript-developers%2F&#39;,&#39;mwp&#39;,&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mwp"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb_toggle_more_popup(&#39;1432656283&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"></span></a></li></ul></div><div class="essb_morepopup essb_morepopup_1432656283 essb_morepopup_postbar essb_morepopup_inline" style="display:none;"> <a href="#" class="essb_morepopup_close" onclick="essb_toggle_less_popup('1432656283'); return false;"><i class="essb_icon_close"></i></a> <div class="essb_morepopup_content essb_morepopup_content_1432656283"><div class="essb_links essb_displayed_more_popup essb_share essb_template_light-retina essb_63293488 essb_links_center print-no" id="essb_displayed_more_popup_63293488" data-essb-postid="7349" data-essb-position="more_popup" data-essb-button-style="icon" data-essb-template="light-retina" data-essb-counter-pos="left" data-essb-url="https://wesharethis.com/2017/08/atom-javascript-developers/" data-essb-twitter-url="https://wesharethis.com/2017/08/atom-javascript-developers/" data-essb-instance="63293488"><ul class="essb_links_list essb_force_hide_name essb_force_hide"></ul></div></div><div class="modal-pointer modal-pointer-up-left"><div class="modal-pointer-conceal"></div></div></div> <div class="essb_morepopup_shadow essb_morepopup_shadow_1432656283" onclick="essb_toggle_less_popup('1432656283'); return false;"></div></div><div class="essb-postbar-next-post"><a href="https://wesharethis.com/2017/08/hayaku-write-css-faster/"><i class="essb_icon_next"></i></a><div class="essb_next_post"><div class="essb_next_post_info"><div class="essb-postbar-close-postpopup essb-postbar-close-next">X</div><a href="https://wesharethis.com/2017/08/hayaku-write-css-faster/"><span class="essb_title"><span class="essb_tcategory">Hayaku &#8211; Write CSS faster</span><span class="essb_category">Developer</span><span class="essb_tdesc">Hayaku is a collection of useful scripts that help with fast web development. Hayaku provides a way to quickly write and support CSS code in the edit&hellip;</span></span></a></div></div></div></div></div></div><script type="text/javascript">jQuery(document).ready(function() {<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6069091752747360",
    enable_page_level_ads: true
  });
</script>});</script>                <script type="text/javascript">
                    jQuery(function () {
                        jQuery(".wiki-like a").click(function () {
                            like = jQuery(this);
                            post_id = like.data("post_id");
                            // Ajax call
                            jQuery.ajax({
                                type: "post",
                                url: "https://wesharethis.com/wp-admin/admin-ajax.php",
                                data: "action=blogPostLike&nonce=bfc7ac26ed&post_like=&post_id=" + post_id,
                                success: function (count) {
                                    if (count != "already") {
                                        like.closest(".wiki-like").addClass("voted");
                                        like.siblings(".count").text(count);
                                    }
                                }
                            });
                            return false;
                        });
                    });
                </script>
                	<!--[if lte IE 8]>
	<style>
		.attachment:focus {
			outline: #1e8cbe solid;
		}
		.selected.attachment {
			outline: #1e8cbe solid;
		}
	</style>
	<![endif]-->
	<script type="text/html" id="tmpl-media-frame">
		<div class="media-frame-menu"></div>
		<div class="media-frame-title"></div>
		<div class="media-frame-router"></div>
		<div class="media-frame-content"></div>
		<div class="media-frame-toolbar"></div>
		<div class="media-frame-uploader"></div>
	</script>

	<script type="text/html" id="tmpl-media-modal">
		<div class="media-modal wp-core-ui">
			<button type="button" class="media-modal-close"><span class="media-modal-icon"><span class="screen-reader-text">Close media panel</span></span></button>
			<div class="media-modal-content"></div>
		</div>
		<div class="media-modal-backdrop"></div>
	</script>

	<script type="text/html" id="tmpl-uploader-window">
		<div class="uploader-window-content">
			<h1>Drop files to upload</h1>
		</div>
	</script>

	<script type="text/html" id="tmpl-uploader-editor">
		<div class="uploader-editor-content">
			<div class="uploader-editor-title">Drop files to upload</div>
		</div>
	</script>

	<script type="text/html" id="tmpl-uploader-inline">
		<# var messageClass = data.message ? 'has-upload-message' : 'no-upload-message'; #>
		<# if ( data.canClose ) { #>
		<button class="close dashicons dashicons-no"><span class="screen-reader-text">Close uploader</span></button>
		<# } #>
		<div class="uploader-inline-content {{ messageClass }}">
		<# if ( data.message ) { #>
			<h2 class="upload-message">{{ data.message }}</h2>
		<# } #>
					<div class="upload-ui">
				<h2 class="upload-instructions drop-instructions">Drop files anywhere to upload</h2>
				<p class="upload-instructions drop-instructions">or</p>
				<button type="button" class="browser button button-hero">Select Files</button>
			</div>

			<div class="upload-inline-status"></div>

			<div class="post-upload-ui">
				
				<p class="max-upload-size">Maximum upload file size: 128 MB.</p>

				<# if ( data.suggestedWidth && data.suggestedHeight ) { #>
					<p class="suggested-dimensions">
						Suggested image dimensions: {{data.suggestedWidth}} by {{data.suggestedHeight}} pixels.					</p>
				<# } #>

							</div>
				</div>
	</script>

	<script type="text/html" id="tmpl-media-library-view-switcher">
		<a href="/2017/08/atom-javascript-developers/?mode=list" class="view-list">
			<span class="screen-reader-text">List View</span>
		</a>
		<a href="/2017/08/atom-javascript-developers/?mode=grid" class="view-grid current">
			<span class="screen-reader-text">Grid View</span>
		</a>
	</script>

	<script type="text/html" id="tmpl-uploader-status">
		<h2>Uploading</h2>
		<button type="button" class="button-link upload-dismiss-errors"><span class="screen-reader-text">Dismiss Errors</span></button>

		<div class="media-progress-bar"><div></div></div>
		<div class="upload-details">
			<span class="upload-count">
				<span class="upload-index"></span> / <span class="upload-total"></span>
			</span>
			<span class="upload-detail-separator">&ndash;</span>
			<span class="upload-filename"></span>
		</div>
		<div class="upload-errors"></div>
	</script>

	<script type="text/html" id="tmpl-uploader-status-error">
		<span class="upload-error-filename">{{{ data.filename }}}</span>
		<span class="upload-error-message">{{ data.message }}</span>
	</script>

	<script type="text/html" id="tmpl-edit-attachment-frame">
		<div class="edit-media-header">
			<button class="left dashicons <# if ( ! data.hasPrevious ) { #> disabled <# } #>"><span class="screen-reader-text">Edit previous media item</span></button>
			<button class="right dashicons <# if ( ! data.hasNext ) { #> disabled <# } #>"><span class="screen-reader-text">Edit next media item</span></button>
		</div>
		<div class="media-frame-title"></div>
		<div class="media-frame-content"></div>
	</script>

	<script type="text/html" id="tmpl-attachment-details-two-column">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</script>

	<script type="text/html" id="tmpl-attachment">
		<div class="attachment-preview js--select-attachment type-{{ data.type }} subtype-{{ data.subtype }} {{ data.orientation }}">
			<div class="thumbnail">
				<# if ( data.uploading ) { #>
					<div class="media-progress-bar"><div style="width: {{ data.percent }}%"></div></div>
				<# } else if ( 'image' === data.type && data.sizes ) { #>
					<div class="centered">
						<img src="{{ data.size.url }}" draggable="false" alt="" />
					</div>
				<# } else { #>
					<div class="centered">
						<# if ( data.image && data.image.src && data.image.src !== data.icon ) { #>
							<img src="{{ data.image.src }}" class="thumbnail" draggable="false" alt="" />
						<# } else if ( data.sizes && data.sizes.medium ) { #>
							<img src="{{ data.sizes.medium.url }}" class="thumbnail" draggable="false" alt="" />
						<# } else { #>
							<img src="{{ data.icon }}" class="icon" draggable="false" alt="" />
						<# } #>
					</div>
					<div class="filename">
						<div>{{ data.filename }}</div>
					</div>
				<# } #>
			</div>
			<# if ( data.buttons.close ) { #>
				<button type="button" class="button-link attachment-close media-modal-icon"><span class="screen-reader-text">Remove</span></button>
			<# } #>
		</div>
		<# if ( data.buttons.check ) { #>
			<button type="button" class="check" tabindex="-1"><span class="media-modal-icon"></span><span class="screen-reader-text">Deselect</span></button>
		<# } #>
		<#
		var maybeReadOnly = data.can.save || data.allowLocalEdits ? '' : 'readonly';
		if ( data.describe ) {
			if ( 'image' === data.type ) { #>
				<input type="text" value="{{ data.caption }}" class="describe" data-setting="caption"
					placeholder="Caption this image&hellip;" {{ maybeReadOnly }} />
			<# } else { #>
				<input type="text" value="{{ data.title }}" class="describe" data-setting="title"
					<# if ( 'video' === data.type ) { #>
						placeholder="Describe this video&hellip;"
					<# } else if ( 'audio' === data.type ) { #>
						placeholder="Describe this audio file&hellip;"
					<# } else { #>
						placeholder="Describe this media file&hellip;"
					<# } #> {{ maybeReadOnly }} />
			<# }
		} #>
	</script>

	<script type="text/html" id="tmpl-attachment-details">
		<h2>
			Attachment Details			<span class="settings-save-status">
				<span class="spinner"></span>
				<span class="saved">Saved.</span>
			</span>
		</h2>
		<div class="attachment-info">
			<div class="thumbnail thumbnail-{{ data.type }}">
				<# if ( data.uploading ) { #>
					<div class="media-progress-bar"><div></div></div>
				<# } else if ( 'image' === data.type && data.sizes ) { #>
					<img src="{{ data.size.url }}" draggable="false" alt="" />
				<# } else { #>
					<img src="{{ data.icon }}" class="icon" draggable="false" alt="" />
				<# } #>
			</div>
			<div class="details">
				<div class="filename">{{ data.filename }}</div>
				<div class="uploaded">{{ data.dateFormatted }}</div>

				<div class="file-size">{{ data.filesizeHumanReadable }}</div>
				<# if ( 'image' === data.type && ! data.uploading ) { #>
					<# if ( data.width && data.height ) { #>
						<div class="dimensions">{{ data.width }} &times; {{ data.height }}</div>
					<# } #>

					<# if ( data.can.save && data.sizes ) { #>
						<a class="edit-attachment" href="{{ data.editLink }}&amp;image-editor" target="_blank">Edit Image</a>
					<# } #>
				<# } #>

				<# if ( data.fileLength ) { #>
					<div class="file-length">Length: {{ data.fileLength }}</div>
				<# } #>

				<# if ( ! data.uploading && data.can.remove ) { #>
											<button type="button" class="button-link delete-attachment">Delete Permanently</button>
									<# } #>

				<div class="compat-meta">
					<# if ( data.compat && data.compat.meta ) { #>
						{{{ data.compat.meta }}}
					<# } #>
				</div>
			</div>
		</div>

		<label class="setting" data-setting="url">
			<span class="name">URL</span>
			<input type="text" value="{{ data.url }}" readonly />
		</label>
		<# var maybeReadOnly = data.can.save || data.allowLocalEdits ? '' : 'readonly'; #>
				<label class="setting" data-setting="title">
			<span class="name">Title</span>
			<input type="text" value="{{ data.title }}" {{ maybeReadOnly }} />
		</label>
				<# if ( 'audio' === data.type ) { #>
				<label class="setting" data-setting="artist">
			<span class="name">Artist</span>
			<input type="text" value="{{ data.artist || data.meta.artist || '' }}" />
		</label>
				<label class="setting" data-setting="album">
			<span class="name">Album</span>
			<input type="text" value="{{ data.album || data.meta.album || '' }}" />
		</label>
				<# } #>
		<label class="setting" data-setting="caption">
			<span class="name">Caption</span>
			<textarea {{ maybeReadOnly }}>{{ data.caption }}</textarea>
		</label>
		<# if ( 'image' === data.type ) { #>
			<label class="setting" data-setting="alt">
				<span class="name">Alt Text</span>
				<input type="text" value="{{ data.alt }}" {{ maybeReadOnly }} />
			</label>
		<# } #>
		<label class="setting" data-setting="description">
			<span class="name">Description</span>
			<textarea {{ maybeReadOnly }}>{{ data.description }}</textarea>
		</label>
	</script>

	<script type="text/html" id="tmpl-media-selection">
		<div class="selection-info">
			<span class="count"></span>
			<# if ( data.editable ) { #>
				<button type="button" class="button-link edit-selection">Edit Selection</button>
			<# } #>
			<# if ( data.clearable ) { #>
				<button type="button" class="button-link clear-selection">Clear</button>
			<# } #>
		</div>
		<div class="selection-view"></div>
	</script>

	<script type="text/html" id="tmpl-attachment-display-settings">
		<h2>Attachment Display Settings</h2>

		<# if ( 'image' === data.type ) { #>
			<label class="setting align">
				<span>Alignment</span>
				<select class="alignment"
					data-setting="align"
					<# if ( data.userSettings ) { #>
						data-user-setting="align"
					<# } #>>

					<option value="left">
						Left					</option>
					<option value="center">
						Center					</option>
					<option value="right">
						Right					</option>
					<option value="none" selected>
						None					</option>
				</select>
			</label>
		<# } #>

		<div class="setting">
			<label>
				<# if ( data.model.canEmbed ) { #>
					<span>Embed or Link</span>
				<# } else { #>
					<span>Link To</span>
				<# } #>

				<select class="link-to"
					data-setting="link"
					<# if ( data.userSettings && ! data.model.canEmbed ) { #>
						data-user-setting="urlbutton"
					<# } #>>

				<# if ( data.model.canEmbed ) { #>
					<option value="embed" selected>
						Embed Media Player					</option>
					<option value="file">
				<# } else { #>
					<option value="none" selected>
						None					</option>
					<option value="file">
				<# } #>
					<# if ( data.model.canEmbed ) { #>
						Link to Media File					<# } else { #>
						Media File					<# } #>
					</option>
					<option value="post">
					<# if ( data.model.canEmbed ) { #>
						Link to Attachment Page					<# } else { #>
						Attachment Page					<# } #>
					</option>
				<# if ( 'image' === data.type ) { #>
					<option value="custom">
						Custom URL					</option>
				<# } #>
				</select>
			</label>
			<input type="text" class="link-to-custom" data-setting="linkUrl" />
		</div>

		<# if ( 'undefined' !== typeof data.sizes ) { #>
			<label class="setting">
				<span>Size</span>
				<select class="size" name="size"
					data-setting="size"
					<# if ( data.userSettings ) { #>
						data-user-setting="imgsize"
					<# } #>>
											<#
						var size = data.sizes['thumbnail'];
						if ( size ) { #>
							<option value="thumbnail" >
								Thumbnail &ndash; {{ size.width }} &times; {{ size.height }}
							</option>
						<# } #>
											<#
						var size = data.sizes['medium'];
						if ( size ) { #>
							<option value="medium" >
								Medium &ndash; {{ size.width }} &times; {{ size.height }}
							</option>
						<# } #>
											<#
						var size = data.sizes['large'];
						if ( size ) { #>
							<option value="large" >
								Large &ndash; {{ size.width }} &times; {{ size.height }}
							</option>
						<# } #>
											<#
						var size = data.sizes['full'];
						if ( size ) { #>
							<option value="full"  selected='selected'>
								Full Size &ndash; {{ size.width }} &times; {{ size.height }}
							</option>
						<# } #>
									</select>
			</label>
		<# } #>
	</script>

	<script type="text/html" id="tmpl-gallery-settings">
		<h2>Gallery Settings</h2>

		<label class="setting">
			<span>Link To</span>
			<select class="link-to"
				data-setting="link"
				<# if ( data.userSettings ) { #>
					data-user-setting="urlbutton"
				<# } #>>

				<option value="post" <# if ( ! wp.media.galleryDefaults.link || 'post' == wp.media.galleryDefaults.link ) {
					#>selected="selected"<# }
				#>>
					Attachment Page				</option>
				<option value="file" <# if ( 'file' == wp.media.galleryDefaults.link ) { #>selected="selected"<# } #>>
					Media File				</option>
				<option value="none" <# if ( 'none' == wp.media.galleryDefaults.link ) { #>selected="selected"<# } #>>
					None				</option>
			</select>
		</label>

		<label class="setting">
			<span>Columns</span>
			<select class="columns" name="columns"
				data-setting="columns">
									<option value="1" <#
						if ( 1 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						1					</option>
									<option value="2" <#
						if ( 2 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						2					</option>
									<option value="3" <#
						if ( 3 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						3					</option>
									<option value="4" <#
						if ( 4 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						4					</option>
									<option value="5" <#
						if ( 5 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						5					</option>
									<option value="6" <#
						if ( 6 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						6					</option>
									<option value="7" <#
						if ( 7 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						7					</option>
									<option value="8" <#
						if ( 8 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						8					</option>
									<option value="9" <#
						if ( 9 == wp.media.galleryDefaults.columns ) { #>selected="selected"<# }
					#>>
						9					</option>
							</select>
		</label>

		<label class="setting">
			<span>Random Order</span>
			<input type="checkbox" data-setting="_orderbyRandom" />
		</label>

		<label class="setting size">
			<span>Size</span>
			<select class="size" name="size"
				data-setting="size"
				<# if ( data.userSettings ) { #>
					data-user-setting="imgsize"
				<# } #>
				>
									<option value="thumbnail">
						Thumbnail					</option>
									<option value="medium">
						Medium					</option>
									<option value="large">
						Large					</option>
									<option value="full">
						Full Size					</option>
							</select>
		</label>
	</script>

	<script type="text/html" id="tmpl-playlist-settings">
		<h2>Playlist Settings</h2>

		<# var emptyModel = _.isEmpty( data.model ),
			isVideo = 'video' === data.controller.get('library').props.get('type'); #>

		<label class="setting">
			<input type="checkbox" data-setting="tracklist" <# if ( emptyModel ) { #>
				checked="checked"
			<# } #> />
			<# if ( isVideo ) { #>
			<span>Show Video List</span>
			<# } else { #>
			<span>Show Tracklist</span>
			<# } #>
		</label>

		<# if ( ! isVideo ) { #>
		<label class="setting">
			<input type="checkbox" data-setting="artists" <# if ( emptyModel ) { #>
				checked="checked"
			<# } #> />
			<span>Show Artist Name in Tracklist</span>
		</label>
		<# } #>

		<label class="setting">
			<input type="checkbox" data-setting="images" <# if ( emptyModel ) { #>
				checked="checked"
			<# } #> />
			<span>Show Images</span>
		</label>
	</script>

	<script type="text/html" id="tmpl-embed-link-settings">
		<label class="setting link-text">
			<span>Link Text</span>
			<input type="text" class="alignment" data-setting="linkText" />
		</label>
		<div class="embed-container" style="display: none;">
			<div class="embed-preview"></div>
		</div>
	</script>

	<script type="text/html" id="tmpl-embed-image-settings">
		<div class="thumbnail">
			<img src="{{ data.model.url }}" draggable="false" alt="" />
		</div>

					<label class="setting caption">
				<span>Caption</span>
				<textarea data-setting="caption" />
			</label>
		
		<label class="setting alt-text">
			<span>Alt Text</span>
			<input type="text" data-setting="alt" />
		</label>

		<div class="setting align">
			<span>Align</span>
			<div class="button-group button-large" data-setting="align">
				<button class="button" value="left">
					Left				</button>
				<button class="button" value="center">
					Center				</button>
				<button class="button" value="right">
					Right				</button>
				<button class="button active" value="none">
					None				</button>
			</div>
		</div>

		<div class="setting link-to">
			<span>Link To</span>
			<div class="button-group button-large" data-setting="link">
				<button class="button" value="file">
					Image URL				</button>
				<button class="button" value="custom">
					Custom URL				</button>
				<button class="button active" value="none">
					None				</button>
			</div>
			<input type="text" class="link-to-custom" data-setting="linkUrl" />
		</div>
	</script>

	<script type="text/html" id="tmpl-image-details">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</script>

	<script type="text/html" id="tmpl-image-editor">
		<div id="media-head-{{ data.id }}"></div>
		<div id="image-editor-{{ data.id }}"></div>
	</script>

	<script type="text/html" id="tmpl-audio-details">
		<# var ext, html5types = {
			mp3: wp.media.view.settings.embedMimes.mp3,
			ogg: wp.media.view.settings.embedMimes.ogg
		}; #>

				<div class="media-embed media-embed-details">
			<div class="embed-media-settings embed-audio-settings">
				<audio style="visibility: hidden"
	controls
	class="wp-audio-shortcode"
	width="{{ _.isUndefined( data.model.width ) ? 400 : data.model.width }}"
	preload="{{ _.isUndefined( data.model.preload ) ? 'none' : data.model.preload }}"
	<#
	if ( ! _.isUndefined( data.model.autoplay ) && data.model.autoplay ) {
		#> autoplay<#
	}
	if ( ! _.isUndefined( data.model.loop ) && data.model.loop ) {
		#> loop<#
	}
	#>
>
	<# if ( ! _.isEmpty( data.model.src ) ) { #>
	<source src="{{ data.model.src }}" type="{{ wp.media.view.settings.embedMimes[ data.model.src.split('.').pop() ] }}" />
	<# } #>

	<# if ( ! _.isEmpty( data.model.mp3 ) ) { #>
	<source src="{{ data.model.mp3 }}" type="{{ wp.media.view.settings.embedMimes[ 'mp3' ] }}" />
	<# } #>
	<# if ( ! _.isEmpty( data.model.ogg ) ) { #>
	<source src="{{ data.model.ogg }}" type="{{ wp.media.view.settings.embedMimes[ 'ogg' ] }}" />
	<# } #>
	<# if ( ! _.isEmpty( data.model.m4a ) ) { #>
	<source src="{{ data.model.m4a }}" type="{{ wp.media.view.settings.embedMimes[ 'm4a' ] }}" />
	<# } #>
	<# if ( ! _.isEmpty( data.model.wav ) ) { #>
	<source src="{{ data.model.wav }}" type="{{ wp.media.view.settings.embedMimes[ 'wav' ] }}" />
	<# } #>
	</audio>

				<# if ( ! _.isEmpty( data.model.src ) ) {
					ext = data.model.src.split('.').pop();
					if ( html5types[ ext ] ) {
						delete html5types[ ext ];
					}
				#>
				<label class="setting">
					<span>SRC</span>
					<input type="text" disabled="disabled" data-setting="src" value="{{ data.model.src }}" />
					<button type="button" class="button-link remove-setting">Remove audio source</button>
				</label>
				<# } #>
				<# if ( ! _.isEmpty( data.model.mp3 ) ) {
					if ( ! _.isUndefined( html5types.mp3 ) ) {
						delete html5types.mp3;
					}
				#>
				<label class="setting">
					<span>MP3</span>
					<input type="text" disabled="disabled" data-setting="mp3" value="{{ data.model.mp3 }}" />
					<button type="button" class="button-link remove-setting">Remove audio source</button>
				</label>
				<# } #>
				<# if ( ! _.isEmpty( data.model.ogg ) ) {
					if ( ! _.isUndefined( html5types.ogg ) ) {
						delete html5types.ogg;
					}
				#>
				<label class="setting">
					<span>OGG</span>
					<input type="text" disabled="disabled" data-setting="ogg" value="{{ data.model.ogg }}" />
					<button type="button" class="button-link remove-setting">Remove audio source</button>
				</label>
				<# } #>
				<# if ( ! _.isEmpty( data.model.m4a ) ) {
					if ( ! _.isUndefined( html5types.m4a ) ) {
						delete html5types.m4a;
					}
				#>
				<label class="setting">
					<span>M4A</span>
					<input type="text" disabled="disabled" data-setting="m4a" value="{{ data.model.m4a }}" />
					<button type="button" class="button-link remove-setting">Remove audio source</button>
				</label>
				<# } #>
				<# if ( ! _.isEmpty( data.model.wav ) ) {
					if ( ! _.isUndefined( html5types.wav ) ) {
						delete html5types.wav;
					}
				#>
				<label class="setting">
					<span>WAV</span>
					<input type="text" disabled="disabled" data-setting="wav" value="{{ data.model.wav }}" />
					<button type="button" class="button-link remove-setting">Remove audio source</button>
				</label>
				<# } #>
				
				<# if ( ! _.isEmpty( html5types ) ) { #>
				<div class="setting">
					<span>Add alternate sources for maximum HTML5 playback:</span>
					<div class="button-large">
					<# _.each( html5types, function (mime, type) { #>
					<button class="button add-media-source" data-mime="{{ mime }}">{{ type }}</button>
					<# } ) #>
					</div>
				</div>
				<# } #>

				<div class="setting preload">
					<span>Preload</span>
					<div class="button-group button-large" data-setting="preload">
						<button class="button" value="auto">Auto</button>
						<button class="button" value="metadata">Metadata</button>
						<button class="button active" value="none">None</button>
					</div>
				</div>

				<label class="setting checkbox-setting autoplay">
					<input type="checkbox" data-setting="autoplay" />
					<span>Autoplay</span>
				</label>

				<label class="setting checkbox-setting">
					<input type="checkbox" data-setting="loop" />
					<span>Loop</span>
				</label>
			</div>
		</div>
	</script>

	<script type="text/html" id="tmpl-video-details">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</script>

	<script type="text/html" id="tmpl-editor-gallery">
		<# if ( data.attachments.length ) { #>
			<div class="gallery gallery-columns-{{ data.columns }}">
				<# _.each( data.attachments, function( attachment, index ) { #>
					<dl class="gallery-item">
						<dt class="gallery-icon">
							<# if ( attachment.thumbnail ) { #>
								<img src="{{ attachment.thumbnail.url }}" width="{{ attachment.thumbnail.width }}" height="{{ attachment.thumbnail.height }}" alt="" />
							<# } else { #>
								<img src="{{ attachment.url }}" alt="" />
							<# } #>
						</dt>
						<# if ( attachment.caption ) { #>
							<dd class="wp-caption-text gallery-caption">
								{{{ data.verifyHTML( attachment.caption ) }}}
							</dd>
						<# } #>
					</dl>
					<# if ( index % data.columns === data.columns - 1 ) { #>
						<br style="clear: both;">
					<# } #>
				<# } ); #>
			</div>
		<# } else { #>
			<div class="wpview-error">
				<div class="dashicons dashicons-format-gallery"></div><p>No items found.</p>
			</div>
		<# } #>
	</script>

	<script type="text/html" id="tmpl-crop-content">
		<img class="crop-image" src="{{ data.url }}" alt="Image crop area preview. Requires mouse interaction.">
		<div class="upload-errors"></div>
	</script>

	<script type="text/html" id="tmpl-site-icon-preview">
		<h2>Preview</h2>
		<strong aria-hidden="true">As a browser icon</strong>
		<div class="favicon-preview">
			<img src="https://wesharethis.com/wp-admin/images/browser.png" class="browser-preview" width="182" height="" alt="" />

			<div class="favicon">
				<img id="preview-favicon" src="{{ data.url }}" alt="Preview as a browser icon"/>
			</div>
			<span class="browser-title" aria-hidden="true">Wesharethis</span>
		</div>

		<strong aria-hidden="true">As an app icon</strong>
		<div class="app-icon-preview">
			<img id="preview-app-icon" src="{{ data.url }}" alt="Preview as an app icon"/>
		</div>
	</script>

	<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/admin-bar.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_notices = {"es_email_notice":"Please enter email address","es_incorrect_email":"Please provide a valid email address","es_load_more":"loading...","es_ajax_error":"Cannot create XMLHTTP instance","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Within a few minutes, kindly check the mail in your mailbox and confirm your subscription. If you can't see the mail in your mailbox, please check your spam folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_problem_request":"There was a problem with the request"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/email-subscribers/widget/es-widget.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_page_notices = {"es_email_notice":"Please enter email address","es_incorrect_email":"Please provide a valid email address","es_load_more":"loading...","es_ajax_error":"Cannot create XMLHTTP instance","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Within a few minutes, kindly check the mail in your mailbox and confirm your subscription. If you can't see the mail in your mailbox, please check your spam folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_problem_request":"There was a problem with the request"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/email-subscribers/widget/es-widget-page.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tocplus = {"smooth_scroll":"1","visibility_show":"show","visibility_hide":"hide","width":"Auto"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=1509'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/mivhak/vendor/askupa-software/amarkal-framework/Assets/js/select2.min.js?ver=0.3.7'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/ace/1.2.3/ace.js?ver=1.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mivhak_settings = {"line_numbers":"1","auto_assign":"PRE,CODE,XHR","show_meta":"1","min_lines":"1","default_lang":"","font_size":"12","theme":"dawn","version":"1.3.6","lang_list":{"abap":"ABAP","abc":"ABC","actionscript":"ActionScript","ada":"Ada","apache_conf":"ApacheConf","applescript":"AppleScript","asciidoc":"AsciiDoc","assembly_x86":"Assembly x86","autohotkey":"AutoHotkey","batchfile":"Batch File","c9search":"c9search","c_cpp":"C\/C++","cirru":"cirru","clojure":"Clojure","cobol":"COBOL","coffee":"CoffeeScript","coldfusion":"ColdFusion","csharp":"C#","css":"CSS","curly":"Curly","d":"D","dart":"Dart","diff":"diff","django":"Django","dockerfile":"Dockerfile","dot":"DOT","eiffel":"Eiffel","ejs":"EJS","elixir":"Elixir","elm":"Elm","erlang":"Erlang","forth":"Forth","ftl":"FTL","gcode":"G-Code","gherkin":"Gherkin","gitignore":"gitignore","glsl":"GLSL","gobstones":"gobstones","golang":"Go","groovy":"Groovy","haml":"Haml","handlebars":"Handlebars","haskell":"Haskell","haxe":"Haxe","html":"HTML","html_elixir":"HTML Elixir","html_ruby":"HTML Ruby","ini":"INI","io":"io","jack":"JACK","jade":"Jade","java":"Java","javascript":"JavaScript","json":"JSON","jsoniq":"JSONiq","jsp":"JSP","jsx":"JSX","julia":"Julia","latex":"LaTex","lean":"Lean","less":"Less","liquid":"Liquid","lisp":"Lisp","livescript":"LiveScript","logiql":"LogiQL","lsl":"LSL","lua":"Lua","luapage":"Luapage","lucene":"Lucene","makefile":"Makefile","markdown":"Markdown","mask":"Mask","matlab":"MATLAB","maze":"Maze","mel":"MEL","mipsassembler":"MIPS Assembler","mushcode":"MUSHCode","mysql":"MySQL","nix":"nix","nsis":"NSIS","objectivec":"Objective-C","ocaml":"OCaml","pascal":"Pascal","perl":"Perl","pgsql":"pgSQL","php":"PHP","plain_text":"Plain Text","powershell":"PowerShell","praat":"Praat","prolog":"Prolog","properties":"Properties","protobuf":"Protocol Bufffers","python":"Python","r":"R","razor":"Razor","rdoc":"RDoc","rhtml":"rhtml","rst":"reStructuredText","ruby":"Ruby","rust":"Rust","sass":"Sass","scad":"SCAD","scala":"Scala","scheme":"Scheme","scss":"SCSS","sh":"sh","sjs":"SJS","smarty":"Smarty","snippets":"Snippets","soy_template":"Soy Template","space":"Space","sql":"SQL","sqlserver":"SQLServer","stylus":"Stylus","svg":"SVG","swift":"Swift","swig":"Swig","tcl":"Tcl","tex":"Tex","text":"Text","textile":"Textile","toml":"Toml","twig":"Twig","typescript":"TypeScript","vala":"Vala","vbscript":"VBScript","velocity":"Velocity","verilog":"Verilog","vhdl":"VHDL","wollok":"Wollok","xml":"XML","xquery":"XQuery","yaml":"YAML"},"i18n":["line","lines","Copy this code to clipboard","Open this code in a new window","Wrap lines","Show code","About"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/mivhak/assets/js/mivhak.min.js?ver=1.3.6'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/themes/WesharethisV2/framework-customizations/extensions/woffice-directory/static/js/directory.js?ver=1.0'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/themes/WesharethisV2/framework-customizations/extensions/woffice-poll/static/js/woffice-poll-scripts.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/themes/WesharethisV2/framework-customizations/extensions/woffice-wiki/static/js/wiki.js?ver=1.0'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/Easy%20social%20share/lib/modules/social-image-share/assets/js/easy-social-image-share.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/themes/WesharethisV2/js/plugins.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/themes/WesharethisV2/js/fixed-nav.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var touch_handler_args = {"use_force_responsive":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/themes/WesharethisV2/js/scripts.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/shortcode.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/backbone.min.js?ver=1.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/wp-util.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/wp-backbone.min.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpMediaModelsL10n = {"settings":{"ajaxurl":"\/wp-admin\/admin-ajax.php","post":{"id":0}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/media-models.min.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pluploadL10n = {"queue_limit_exceeded":"You have attempted to queue too many files.","file_exceeds_size_limit":"%s exceeds the maximum upload size for this site.","zero_byte_file":"This file is empty. Please try another.","invalid_filetype":"Sorry, this file type is not permitted for security reasons.","not_an_image":"This file is not an image. Please try another.","image_memory_exceeded":"Memory exceeded. Please try another smaller file.","image_dimensions_exceeded":"This is larger than the maximum size. Please try another.","default_error":"An error occurred in the upload. Please try again later.","missing_upload_url":"There was a configuration error. Please contact the server administrator.","upload_limit_exceeded":"You may only upload 1 file.","http_error":"HTTP error.","upload_failed":"Upload failed.","big_upload_failed":"Please try uploading this file with the %1$sbrowser uploader%2$s.","big_upload_queued":"%s exceeds the maximum upload size for the multi-file uploader when used in your browser.","io_error":"IO error.","security_error":"Security error.","file_cancelled":"File canceled.","upload_stopped":"Upload stopped.","dismiss":"Dismiss","crunching":"Crunching\u2026","deleted":"moved to the trash.","error_uploading":"\u201c%s\u201d has failed to upload."};
var _wpPluploadSettings = {"defaults":{"runtimes":"html5,flash,silverlight,html4","file_data_name":"async-upload","url":"\/wp-admin\/async-upload.php","flash_swf_url":"https:\/\/wesharethis.com\/wp-includes\/js\/plupload\/plupload.flash.swf","silverlight_xap_url":"https:\/\/wesharethis.com\/wp-includes\/js\/plupload\/plupload.silverlight.xap","filters":{"max_file_size":"134217728b","mime_types":[{"extensions":"jpg,jpeg,jpe,gif,png,bmp,tiff,tif,ico,asf,asx,wmv,wmx,wm,avi,divx,flv,mov,qt,mpeg,mpg,mpe,mp4,m4v,ogv,webm,mkv,3gp,3gpp,3g2,3gp2,txt,asc,c,cc,h,srt,csv,tsv,ics,rtx,css,vtt,dfxp,mp3,m4a,m4b,ra,ram,wav,ogg,oga,mid,midi,wma,wax,mka,rtf,js,pdf,class,tar,zip,gz,gzip,rar,7z,psd,xcf,doc,pot,pps,ppt,wri,xla,xls,xlt,xlw,mdb,mpp,docx,docm,dotx,dotm,xlsx,xlsm,xlsb,xltx,xltm,xlam,pptx,pptm,ppsx,ppsm,potx,potm,ppam,sldx,sldm,onetoc,onetoc2,onetmp,onepkg,oxps,xps,odt,odp,ods,odg,odc,odb,odf,wp,wpd,key,numbers,pages"}]},"multipart_params":{"action":"upload-attachment","_wpnonce":"916e045762"}},"browser":{"mobile":false,"supported":true},"limitExceeded":false};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/plupload/wp-plupload.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.22.0'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpMediaViewsL10n = {"url":"URL","addMedia":"Add Media","search":"Search","select":"Select","cancel":"Cancel","update":"Update","replace":"Replace","remove":"Remove","back":"Back","selected":"%d selected","dragInfo":"Drag and drop to reorder media files.","uploadFilesTitle":"Upload Files","uploadImagesTitle":"Upload Images","mediaLibraryTitle":"Media Library","insertMediaTitle":"Insert Media","createNewGallery":"Create a new gallery","createNewPlaylist":"Create a new playlist","createNewVideoPlaylist":"Create a new video playlist","returnToLibrary":"\u2190 Return to library","allMediaItems":"All media items","allDates":"All dates","noItemsFound":"No items found.","insertIntoPost":"Insert into post","unattached":"Unattached","trash":"Trash","uploadedToThisPost":"Uploaded to this post","warnDelete":"You are about to permanently delete this item from your site.\nThis action cannot be undone.\n 'Cancel' to stop, 'OK' to delete.","warnBulkDelete":"You are about to permanently delete these items from your site.\nThis action cannot be undone.\n 'Cancel' to stop, 'OK' to delete.","warnBulkTrash":"You are about to trash these items.\n  'Cancel' to stop, 'OK' to delete.","bulkSelect":"Bulk Select","cancelSelection":"Cancel Selection","trashSelected":"Trash Selected","untrashSelected":"Untrash Selected","deleteSelected":"Delete Selected","deletePermanently":"Delete Permanently","apply":"Apply","filterByDate":"Filter by date","filterByType":"Filter by type","searchMediaLabel":"Search Media","searchMediaPlaceholder":"Search media items...","noMedia":"No media files found.","attachmentDetails":"Attachment Details","insertFromUrlTitle":"Insert from URL","setFeaturedImageTitle":"Featured Image","setFeaturedImage":"Set featured image","createGalleryTitle":"Create Gallery","editGalleryTitle":"Edit Gallery","cancelGalleryTitle":"\u2190 Cancel Gallery","insertGallery":"Insert gallery","updateGallery":"Update gallery","addToGallery":"Add to gallery","addToGalleryTitle":"Add to Gallery","reverseOrder":"Reverse order","imageDetailsTitle":"Image Details","imageReplaceTitle":"Replace Image","imageDetailsCancel":"Cancel Edit","editImage":"Edit Image","chooseImage":"Choose Image","selectAndCrop":"Select and Crop","skipCropping":"Skip Cropping","cropImage":"Crop Image","cropYourImage":"Crop your image","cropping":"Cropping\u2026","suggestedDimensions":"Suggested image dimensions: %1$s by %2$s pixels.","cropError":"There has been an error cropping your image.","audioDetailsTitle":"Audio Details","audioReplaceTitle":"Replace Audio","audioAddSourceTitle":"Add Audio Source","audioDetailsCancel":"Cancel Edit","videoDetailsTitle":"Video Details","videoReplaceTitle":"Replace Video","videoAddSourceTitle":"Add Video Source","videoDetailsCancel":"Cancel Edit","videoSelectPosterImageTitle":"Select Poster Image","videoAddTrackTitle":"Add Subtitles","playlistDragInfo":"Drag and drop to reorder tracks.","createPlaylistTitle":"Create Audio Playlist","editPlaylistTitle":"Edit Audio Playlist","cancelPlaylistTitle":"\u2190 Cancel Audio Playlist","insertPlaylist":"Insert audio playlist","updatePlaylist":"Update audio playlist","addToPlaylist":"Add to audio playlist","addToPlaylistTitle":"Add to Audio Playlist","videoPlaylistDragInfo":"Drag and drop to reorder videos.","createVideoPlaylistTitle":"Create Video Playlist","editVideoPlaylistTitle":"Edit Video Playlist","cancelVideoPlaylistTitle":"\u2190 Cancel Video Playlist","insertVideoPlaylist":"Insert video playlist","updateVideoPlaylist":"Update video playlist","addToVideoPlaylist":"Add to video playlist","addToVideoPlaylistTitle":"Add to Video Playlist","settings":{"tabs":[],"tabUrl":"https:\/\/wesharethis.com\/wp-admin\/media-upload.php?chromeless=1","mimeTypes":{"image":"Images","audio":"Audio","video":"Video"},"captions":true,"nonce":{"sendToEditor":"183cc8de81","wpRestApi":"0c8e14360a"},"post":{"id":0},"defaultProps":{"link":"none","align":"","size":""},"attachmentCounts":{"audio":1,"video":1},"oEmbedProxyUrl":"https:\/\/wesharethis.com\/wp-json\/oembed\/1.0\/proxy","embedExts":["mp3","ogg","m4a","wav","mp4","m4v","webm","ogv","flv"],"embedMimes":{"mp3":"audio\/mpeg","ogg":"audio\/ogg","m4a":"audio\/mpeg","wav":"audio\/wav","mp4":"video\/mp4","m4v":"video\/mp4","webm":"video\/webm","ogv":"video\/ogg","flv":"video\/x-flv"},"contentWidth":null,"months":[{"year":"2017","month":"8","text":"August 2017"},{"year":"2017","month":"7","text":"July 2017"},{"year":"2017","month":"6","text":"June 2017"},{"year":"2017","month":"5","text":"May 2017"},{"year":"2017","month":"4","text":"April 2017"},{"year":"2015","month":"4","text":"April 2015"},{"year":"2014","month":"11","text":"November 2014"},{"year":"2013","month":"6","text":"June 2013"}],"mediaTrash":0}};
/* ]]> */
</script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/media-views.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/media-editor.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/media-audiovideo.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://wesharethis.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.4'></script>
        <script>if( typeof QTags !== 'undefined' ){QTags.addButton( 'pre', 'pre', '<pre>', '</pre>\n', 'p', '', 105 );}</script>
                <script type="text/javascript">
                (function ($) {
                                        var $dashboard = $('#dashboard').isotope({
                        // options
                        itemSelector: '.widget',
                        layoutMode: 'masonry'
                    });
                    setTimeout(function () {
                        $dashboard.isotope();
                    }, 200);
                                    }(jQuery));
            </script>
            <div class="essbasc-popup essbasc-popup-follow" data-popup-width="500"><a href="#" class="essbasc-popup-close" onclick="essbasc_popup_close(); return false;"></a><div class="essbasc-popup-content"><div class="essbasc-text-before">Turn up.. Let's be friends on social networks also</div><div class="essbasc-fans twocols"><div class="essbasc-fans-single essbasc-fans-facebook">
				<div class="essbasc-fans-icon">
					<i class="essb_icon_facebook"></i>
				</div>
				<div class="essbasc-fans-text">
		<div class="fb-like" data-href="https://facebook.com/Wesharethistech" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
		</div>
		</div><div class="essbasc-fans-single essbasc-fans-google">
				<div class="essbasc-fans-icon">
					<i class="essb_icon_google"></i>
				</div>
				<div class="essbasc-fans-text">
		<div class="g-plusone" data-size="medium" data-href="https://plus.google.com/+Olamouslat"></div>
		</div>
		</div><div class="essbasc-fans-single essbasc-fans-twitter">
				<div class="essbasc-fans-icon">
					<i class="essb_icon_twitter"></i>
				</div>
				<div class="essbasc-fans-text">
		<a href="https://twitter.com/Wesharethis" class="twitter-follow-button" data-show-count="true" data-show-screen-name="false">Follow @Wesharethis</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
		</div>
		</div><div class="essbasc-fans-single essbasc-fans-linkedin">
				<div class="essbasc-fans-icon">
					<i class="essb_icon_linkedin"></i>
				</div>
				<div class="essbasc-fans-text">
		<script src="//platform.linkedin.com/in.js" type="text/javascript">lang: en_US</script><script type="IN/FollowCompany" data-id="mouslat" data-counter="right"></script>
		</div>
		</div></div></div></div><div class="essbasc-popup-shadow" onclick="essbasc_popup_close();"></div><script type="text/javascript">var essbasc_cookie_live = 7;</script><link rel="stylesheet" id="easy-social-share-buttons-popupasc"  href="https://wesharethis.com/wp-content/plugins/Easy social share/assets/css/essb-after-share-close.min.css" type="text/css" media="all" /><link rel="stylesheet" id="essb-social-image-share"  href="https://wesharethis.com/wp-content/plugins/Easy social share/lib/modules/social-image-share/assets/css/easy-social-image-share.min.css" type="text/css" media="all" /><link rel="stylesheet" id="essb-cct-style"  href="https://wesharethis.com/wp-content/plugins/Easy social share/lib/modules/click-to-tweet/assets/css/styles.css" type="text/css" media="all" /><div id="fb-root"></div>
	<script>(function(d, s, id) {
	var js, fjs = d.getElementsByTagName(s)[0];
	if (d.getElementById(id)) return;
	js = d.createElement(s); js.id = id; 
	js.src = "//connect.facebook.net/en_US/sdk.js#version=v2.8&xfbml=1"
	fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
	<script type="text/javascript">
	(function() {
	var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
	po.src = 'https://apis.google.com/js/platform.js';
	var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
})();
</script><script type="text/javascript">
				(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async=true;;
				po.src = 'https://wesharethis.com/wp-content/plugins/Easy social share/assets/js/essb-display-methods.min.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		})();</script><script type="text/javascript">
				(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async=true;;
				po.src = 'https://wesharethis.com/wp-content/plugins/Easy social share/assets/js/essb-after-share-close.min.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		})();</script><script type="text/javascript">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</script>		<div id="wpadminbar" class="nojq nojs">
							<a class="screen-reader-shortcut" href="#wp-toolbar" tabindex="1">Skip to toolbar</a>
						<div class="quicklinks" id="wp-toolbar" role="navigation" aria-label="Toolbar" tabindex="0">
				<ul id="wp-admin-bar-root-default" class="ab-top-menu">
		<li id="wp-admin-bar-wp-logo" class="menupop"><div class="ab-item ab-empty-item" tabindex="0" aria-haspopup="true"><span class="ab-icon"></span><span class="screen-reader-text">About WordPress</span></div><div class="ab-sub-wrapper"><ul id="wp-admin-bar-wp-logo-external" class="ab-sub-secondary ab-submenu">
		<li id="wp-admin-bar-wporg"><a class="ab-item" href="https://wordpress.org/">WordPress.org</a>		</li>
		<li id="wp-admin-bar-documentation"><a class="ab-item" href="https://codex.wordpress.org/">Documentation</a>		</li>
		<li id="wp-admin-bar-support-forums"><a class="ab-item" href="https://wordpress.org/support/">Support Forums</a>		</li>
		<li id="wp-admin-bar-feedback"><a class="ab-item" href="https://wordpress.org/support/forum/requests-and-feedback">Feedback</a>		</li></ul></div>		</li>
		<li id="wp-admin-bar-bp-login"><a class="ab-item" href="https://wesharethis.com/wp-login.php?redirect_to=https%3A%2F%2Fwesharethis.com%2F2017%2F08%2Fatom-javascript-developers%2F">Log in</a>		</li>
		<li id="wp-admin-bar-bp-register"><a class="ab-item" href="https://wesharethis.com/register/">Register</a>		</li></ul><ul id="wp-admin-bar-top-secondary" class="ab-top-secondary ab-top-menu">
		<li id="wp-admin-bar-search" class="admin-bar-search"><div class="ab-item ab-empty-item" tabindex="-1"><form action="https://wesharethis.com/" method="get" id="adminbarsearch"><input class="adminbar-input" name="s" id="adminbar-search" type="text" value="" maxlength="150" /><label for="adminbar-search" class="screen-reader-text">Search</label><input type="submit" class="adminbar-button" value="Search"/></form></div>		</li></ul>			</div>
					</div>

		
	</body>
	<!-- END BODY -->
</html>